About gamerule maxentityCramming


There are 25 minecart and more than 25 witches
But the witch will not be hurt
I want to know why and how do you change it

I use spongeforge-1.11.2-2393-6.1.0-BETA-2458


/gamerule maxEntityCramming 24 is standard and should do the job. Did you tried it with other mobs?

The maximum number of other pushable entities a mob or player can push, before taking 3 (Heart.svgHalf Heart.svg) suffocation damage per half-second. Setting to 0 disables the rule. Damage affects survival-mode or adventure-mode players, and all mobs but bats. Pushable entities include non-spectator-mode players, any mob except bats, as well as boats and minecarts.


Before max entity cramming exists we had a optimization in place to prevent these ‘mob singularity’ from causing lag.

Setting max-entities-within-aabb in the config to 0 (/sponge config max-entities-within-aabb 0) will disable this optimization and return the Mojang default of suffocating them.

I’m not sure if it should be considered a bug or not as it could be argued that it’s working as designed, even if it has a difference of vanilla mechanics by default.


Best would be to write that info somewhere down or change the description of the entry in the documentation to also find it via “maxEntityCramming”



Thanks for your answer.You’re great


Thanks for the suggestion, I’ve taken it on board and created a pull request on your behalf.


On our server I’ve set the max-entities-within-aabb in the config to 0 (/sponge config max-entities-within-aabb 0) to 0 and set Minecraft’s maxEntityCramming to 24 but there is no effect, unlimited entities can still be put into a single 1x1 space. Is there any other fix for this issue? Running Forge and current latest version of Sponge. Any help much appreciated, thanks.


This may be a bug, try setting it to something rediculously high like 999 instead?


Tried it, still no effect. If it’s a bug, should I report it somewhere other than here?


I’ve tested this with Faithcaio dev setup (1.12.2-2555-7.1.0-BETA-2834), so unless it’s a production vs development thing, setting the maxEntityCramming gamerule to 9 worked for me.

If you have modified the config version, rather then changing the gamerule, I assume you have tried restarting, as well as ensuring that you either modified global config, or enabled any per world configs that you edited it in (if applicable)


Really very useful info