Crash server : Completing incorrect phase


#1

Hi ! Can you help me to fix this server crash when starting (after Sponge update) : :slight_smile:

/*****************************************************************************************************************/
/*                                          Completing incorrect phase                                           */
/*****************************************************************************************************************/
/* Sponge's tracking system is very dependent on knowing when a change to any world                              */
/* takes place, however, we are attempting to complete a "phase" other than the one                              */
/* we most recently entered. This is an error usually on Sponge's part, so a report                              */
/* is required on the issue tracker on GitHub.                                                                   */
/*****************************************************************************************************************/
/* Expected to exit phase: EntityTickPhase                                                                       */
/* But instead found phase: TileEntityTickPhase                                                                  */
/* StackTrace:                                                                                                   */
/* java.lang.Exception: null                                                                                     */
/*     org.spongepowered.common.event.tracking.CauseTracker.printIncorrectPhaseCompletion(CauseTracker.java:300) */
/*     org.spongepowered.common.event.tracking.CauseTracker.completePhase(CauseTracker.java:204)                 */
/*     org.spongepowered.common.event.tracking.TrackingUtil.tickTileEntity(TrackingUtil.java:239)                */
/*     net.minecraft.world.WorldServer.updateTileEntity(WorldServer.java:2838)                                   */
/*     net.minecraft.world.WorldServer.redirect$onUpdateTileEntities$zkc000(WorldServer.java:2825)               */
/*     net.minecraft.world.World.func_72939_s(World.java:6063)                                                   */
/*     net.minecraft.world.WorldServer.func_72939_s(WorldServer.java:2197)                                       */
/*     net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:709)                               */
/*     net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:387)                     */
/*     net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:613)                               */
/*     net.minecraft.server.MinecraftServer.run(MinecraftServer.java:471)                                        */
/*     java.lang.Thread.run(Unknown Source)                                                                      */
/*  Phases Remaining:                                                                                            */
/*   - Phase: TileEntityTickPhase                                                                                */
/*     Context:                                                                                                  */
/*     - Name: Source                                                                                            */
/*       Object: net.minecraft.tileentity.TileEntityFurnace@9503cf2                                              */
/*     - Name: CapturedEntities                                                                                  */
/*       Object: CapturedEntitiesSupplier{Captured=0}                                                            */
/*     - Name: CapturedBlocks                                                                                    */
/*       Object: CapturedBlocksSupplier{Captured=0}                                                              */
/*                                                                                                               */
/* Minecraft : 1.10.2                                                                                            */
/* SpongeAPI : 5.2.0-SNAPSHOT-c675e80                                                                            */
/* SpongeForge : 1.10.2-2477-5.2.0-BETA-2776                                                                     */
/* Minecraft Forge : 12.18.3.2477                                                                                */
/*****************************************************************************************************************/

Do you need more information ?


#2

Could you provide the full crash report?


#3

downgrade to 5.2.0-BETA-2731

see https://github.com/SpongePowered/SpongeForge/issues/1898


#4

I encountered the same error when updating sponge this morning. I used 2731 again and the error has disappeared.


#5

This has been fixed in build 2777.


#6

Oh cool ! Fixed with build 2777 !
Thanks all of you !