Enjin CMS + DonationCraft Plugin [v3.4.3] API [5.x, 6.x, 7.x]


#225

In-game rewards for the vote for diamonds module doesn't work for me for some reason... Is it supposed to?


#226

Works for me on 1925


#228

Hello, is it possible if you can add command block compatibility?

I'm setting up a mini-game and rewarding players with points. I try and make the command block do this command:
/enjin addpoints @p 1

The output is this:
[20:46:36] Player is not linked to any valid user.

Do you think you can add compatibility for @p, @r, & @a?

Thanks!


#229

I can look into it, but it probably won't be implemented immediately if I find a decent way of doing this.


#230

So I am having a recurring issue with the newest Enjin Sponge download - it keeps disconnecting. I have tried resetting the key, multiple times, but nothing is amiss. Often, it is by a simple restart that it will disconnect; the website marks the server as Offline and the donations are queued. Again, resetting the key will not work (if you use the same key, it'll say it's already been validated). The server is online, all well, no errors whatsoever. Yet Enjin is not connected.

Once you restart (and you have the good luck of having it connected again), the donations will suddenly flow in, even after hours of inactivity. This causes a major problem whenever I need to give someone a donation, and it ends up being "wait for next restart to get your donation".

I am using API5.1.0-sponge 2000, with Forge 2171. I have tried downgrading, with a different Forge and Sponge. I still have an older version of the same enjin plugin (one that was probably released two months ago) and that one has a higher success rate on the connection department. But it also spams errors all the time, so an update is needed.

EDIT: I am in high need for having this fixed, as I cannot use my enjin site without it. 80% of the time, the server is offline, affecting donations, forums, permission syncing as well as status updates.


#231

Send us a ticket at https://www.enjin.com/support and I will work with you to solve this problem. We're aware that this has been an issue for some people, but we've been unable to ascertain the cause.


#232

having the exact same problem...


#233

I have sent in a ticket. I certainly do hope it'll get fixed quickly, as it makes my server donations (at this very busy time) useless.


#234

on my server when it goes offline like this; if you type /enjin it will crash the server... wasnt doing this until recently..


#235

Do you have a ticket number that I can refer to?

** EDIT **
Nevermind, I found the ticket. If you can go ahead and do as Chris asked in his reply that would be a good first step.


#236

I just have sent him a reply - the report command does not work. Should I keep you posted through this?
EDIT: @Khaoz I don't crash though


#237

Don't worry, I assigned myself to the ticket so I'll be the one you'll be corresponding with on the ticket. I'll reply tomorrow as I'm just about finished with work for today.


#238

any update on the cause for the plugin to go offline randomly? really not wanting to switch to buycraft after just renewing my subscription to enjin a few days ago just to not be able to use the website at all


#239

No, it's not a simple fix. You'll have to wait patiently until we manage to find the cause.


#240

Version 3.0.16 released

-Improve exception logging
-Minor fix for mineshafter support
-Add some additional debug to logs

Download Enjin Plugin v3.0.16


#241

@Favorlock I had a similar issue about a month ago and I opened a ticket. I believe Chris did some changes on the backend of our website and it worked perfect ever since. Have not disconnected at all. Hopefully you can track down what he did on our website to fix all the issues for the others as well. I can vouch I am using same Forge/Sponge as Rasgnarok. Site link can be found on the Sponge dev hiring forums located here. (not trying to advertise just help debug). That's the site I created the ticket under so you can search for it on your systems


#242

Chris said that he didn't make any changes, so I'm not exactly sure what the cause is, but it seems to happen at some times and not others I guess.


#243

So after doing a little research into how the target selectors work I think it's reasonable to add such a feature. While this won't be implemented immediately, it'll be one of the features I'll put on my priority to do list after I complete the major refactor to the plugin I'm currently working on.


#244

Thanks for looking into it!


#245

When using the latest version of this, and NuVotifier, the server crashes because:

Description: Exception in server tick loop
Duplicate Mods:
    nuvotifier : /mods/nuvotifier-2.3.3.jar
    nuvotifier : /mods/EMPSponge.jar

Any fix for this?