Enjin CMS + DonationCraft Plugin [v3.4.3] API [5.x, 6.x, 7.x]


#327

I submitted a new build earlier to the web team. Just waiting for them to push the new build live and update this thread.


#328

When will the new Version be out for api 7 as I have been waiting almost two months for this plugin


#329

As I literally just said in the reply before you, just waiting on the web team to push the build live and update the thread. There is no ETA beyond “soon”.


#330

Version 3.4.1 released

  • Log server id to enjin report
  • Update to Sponge API v7.x (Not backwards compatible)
  • Fix decimal formatting in sponge gui shop

Download Enjin Minecraft Plugin v3.4.1 [API v7.x]


#331

Version 3.4.3 released

  • Add check for case where stat sign is above the skull
  • Fix conflicting FileAppender settings
  • Run commands with an id of 0 but do not report completion to web api
  • Fix name length checking logic
  • Fix bug where RankUpdates was loading a null config because the rankUpdates.json was empty
  • Replace /buy in strings with the configured command string

Download Enjin Minecraft Plugin v3.4.3 [API v7.x]
Download Enjin Minecraft Plugin v3.4.3 [API v6.x]


#332

Are those compatible with API 5 and if not which version should we use for API 5?


#333

Currently having issues with FoolCraft 2.4 (Latest verson) and using sponge with enjin. Server is not showing as online tho the plugin displays this “The key has been successfully validated”

Has anyone come across this?

Foolcraft is MC 1.10 and im using API v7 (v3.4.3)

Thanks

Josh


#334

API 7 is 1.12+, 1.10.2 is API 5.

Personally I believe I’m using version 3.3.3 (on MC 1.10.2), but I have no way to check.


#335

@yepidoodles Oh! I’ll try that. Thanks :slight_smile:


#336

To my knowledge you are correct. 1.10.2 supports 5.x/6.x. Our 6.x compatible plugins should also work with 5.x as I don’t believe we relied on any api features that had changed between the two.


#337

Is this working for 1.12? I can’t get it to do anything.

Trying to set up an FTB Horizons server

With the server loaded and running, there are no /enjin* commands, and the Enjinminecraftplugin directory remains empty.

Some guides mention “Vault” but this is not listed as needed for the new version 7 for Sponge.

VERSIONS USED::
minecraft_server.1.12.2.jar
MinecraftForge v14.23.0.2531
spongeforge-1.12.2-2555-7.0.0-BETA-2768.jar (newest)
EMPSponge7.x-ver3.4.3.jar

LOGS:

fml-early-junk.log:
[Server thread/DEBUG] [FML]: Identified a mod of type Lorg/spongepowered/api/plugin/Plugin; (com.enjin.sponge.EnjinMinecraftPlugin) - loading
[Server thread/WARN] [FML]: Missing English translation for enjin-minecraft-plugin: assets/enjin-minecraft-plugin/lang/en_us.lang
[Server thread/DEBUG] [FML]: enjin-minecraft-plugin(Enjin Minecraft Plugin:3.4.3-sponge7): EMPSponge7.x-ver3.4.3.jar ()

[Server thread/TRACE] [enjin-minecraft-plugin]: Sending event FMLConstructionEvent to mod enjin-minecraft-plugin
[Server thread/DEBUG] [FML]: Attempting to inject @SidedProxy classes into enjin-minecraft-plugin
[Server thread/TRACE] [enjin-minecraft-plugin]: Sent event FMLConstructionEvent to mod enjin-minecraft-plugin
[Server thread/DEBUG] [FML]: Bar Step: Construction - Enjin Minecraft Plugin took 0.089s

[Server thread/DEBUG] [FML]: Missing Signatures:
[Server thread/DEBUG] [FML]: enjin-minecraft-plugin (Enjin Minecraft Plugin 3.4.3-sponge7) EMPSponge7.x-ver3.4.3.jar

[Server thread/TRACE] [enjin-minecraft-plugin]: Sending event FMLPreInitializationEvent to mod enjin-minecraft-plugin
[Server thread/TRACE] [enjin-minecraft-plugin]: Sent event FMLPreInitializationEvent to mod enjin-minecraft-plugin
[Server thread/DEBUG] [FML]: Bar Step: PreInitialization - Enjin Minecraft Plugin took 0.000s

[Server thread/INFO] [EnjinMinecraftPlugin]: Log4j 2 handler detected: com.enjin.common.compatibility.CurrentLog4j2Handler
[Server thread/WARN] [EnjinMinecraftPlugin]: Could not initialize file appender…
[Server thread/INFO] [EnjinMinecraftPlugin]: Initializing EMP Commands

[Server thread/TRACE] [enjin-minecraft-plugin]: Sending event FMLInitializationEvent to mod enjin-minecraft-plugin
[Server thread/TRACE] [enjin-minecraft-plugin]: Sent event FMLInitializationEvent to mod enjin-minecraft-plugin
[Server thread/DEBUG] [FML]: Bar Step: Initialization - Enjin Minecraft Plugin took 0.000s

[Server thread/TRACE] [FML]: Attempting to deliver 0 IMC messages to mod enjin-minecraft-plugin
[Server thread/TRACE] [enjin-minecraft-plugin]: Sending event IMCEvent to mod enjin-minecraft-plugin
[Server thread/TRACE] [enjin-minecraft-plugin]: Sent event IMCEvent to mod enjin-minecraft-plugin
[Server thread/DEBUG] [FML]: Bar Step: InterModComms$IMC - Enjin Minecraft Plugin took 0.000s

[Server thread/TRACE] [enjin-minecraft-plugin]: Sending event FMLPostInitializationEvent to mod enjin-minecraft-plugin
[Server thread/TRACE] [enjin-minecraft-plugin]: Sent event FMLPostInitializationEvent to mod enjin-minecraft-plugin
[Server thread/DEBUG] [FML]: Bar Step: PostInitialization - Enjin Minecraft Plugin took 0.000s

The previous three lines appear several more times.

No /enjin commands found at the console, so apparently it did not load correctly?


#338

when i type /buy an di want to click on link in shop it doesnt work , any way ?how to set it up ?