Fatally missing registry entries


#1

I’m currently running spongeforge-1.12.2-2655-7.1.0-BETA-3080.

Whenever I try to join on my client, I get this message:

Here’s my server log: https://hastebin.com/oxinifixiy.md
And here’s my client log: https://hastebin.com/rudavaxahi.md

Mod List
  • The Official Connected Textures Pack (by Drullkus)
  • Ceramics (by KnightMiner)
  • Iron Chests (by progwml6)
  • B.A.S.E (by lanse505)
  • Clumps (by jaredlll08)
  • Extra Utilities (by RWTema)
  • Angel Ring To Bauble (by Portablejim)
  • Mob Grinding Utils (by Vadis365)
  • iChunUtil (by iChun)
  • GooglyEyes (by iChun)
  • Hats (by iChun)
  • Creeper Confetti (by SR261097)
  • Mantle (by mDiyo)
  • Biomes O’ Plenty (by Glitchfiend)
  • Bad Wither No Cookie - Reloaded (by kreezxil)
  • Better Builder’s Wands (by Portablejim)
  • BetterFps (by Guichaguri)
  • Shadowfacts’ Forgelin (by shadowfactsmc)
  • ShadowMC (by shadowfactsmc)
  • Clipboard (by shadowfactsmc)
  • PTRLib (by RazzleberryFox)
  • DecoCraft2 (by RazzleberryFox)
  • CodeChicken Lib 1.8.+ (by covers1624)
  • Ender Storage 1.8.+ (by covers1624)
  • Fast Leaf Decay (by Olafskii)
  • Just Enough Items (JEI) (by mezz)
  • McJtyLib (by McJty)
  • Morpheus (by Quetzi)
  • OpenModsLib (by OpenMods)
  • OpenBlocks (by OpenMods)
  • Tinkers Construct (by mDiyo)
  • PlusTiC (by Landmaster_phuong0429)
  • Tinkers’ Complement (by KnightMiner)
  • WanionLib (by WanionCane)
  • UniDict (by WanionCane)
  • AppleSkin (by squeek502)
  • AppleCore (by squeek502)
  • Better Advancements (by Way2muchnoise)
  • Inventory Tweaks (by Kobata)
  • Baubles (by azanor)
  • Ore Excavation (by Funwayguy)
  • Buildcraft (by CovertJaguar)
  • EnderCore (by tterrag1098)
  • Ender IO (by CrazyPants_MC)
  • ConnectedTexturesMod (by tterrag1098)
  • Chisel (by tterrag1098)
  • Iron Backpacks (by gr8pefish)
  • Hwyla (by TehNut)
  • Pam’s HarvestCraft (by MatrexsVigil)
  • Cooking for Blockheads (by BlayTheNinth)
  • Xaero’s Minimap (by xaero96)
  • Chisels & Bits (by AlgorithmX2)
  • NetherEx (by LogicTechCorp)
  • NetherPortalFix (by BlayTheNinth)
  • Base Metals (by jriwanek)
  • Natura (by mDiyo)
  • Additional Banners (by Darkhax)
  • Wings Horns & Hooves, the Ultimate Unicorn Mod (by KaneApollo)
  • Ender Zoo (by CrazyPants_MC)
  • ShetiPhianCore (by ShetiPhian)
  • EnderTanks (by ShetiPhian)
  • Chickens (by SetyCz)
  • More Chickens (by GenDeathrow)
  • Hatchery (by GenDeathrow)
  • Tinkers’ Addons (by oitsjustjose)
  • Primitive Mobs (by Daveyx0)
  • ExpandedBonemeal (by josephcsible)
  • Baby Mobs (by Furgl)
  • AutoRegLib (by Vazkii)
  • Quark (by Vazkii)
  • Nether Metals (by knoxhack)
  • Modern Metals (by jriwanek)
  • MMD OreSpawn (by jriwanek)
  • End Metals (by jriwanek)
  • Wawla - What Are We Looking At (by Darkhax)
  • Sound Filters (by Tmtravlr)
  • Just a Few Fish (by Tmtravlr)
  • Magma Monsters (by Kashdeya)
  • Mob Dismemberment (by iChun)
  • Soul Shards Respawn (by TehNut)
  • Ruins (Structure Spawning System) (by AtomicStryker)
  • Waystones (by BlayTheNinth)

EDIT: Yes, if I remove Forge then I can connect normally.
EDIT 2: If I remove all the mods besides Sponge on the client and the server then I can connect


#2

You need to update your client’s Java. Sponge requires Java 8 and at least 1.8.0_40 to run.


#3

Issue still persists

Client Java:

java version "1.8.0_151"
Java(TM) SE Runtime Environment (build 1.8.0_151-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.151-b12, mixed mode)

Server Java:

openjdk version "1.8.0_171"
OpenJDK Runtime Environment (build 1.8.0_171-8u171-b11-0ubuntu0.17.10.1-b11)
OpenJDK 64-Bit Server VM (build 25.171-b11, mixed mode) 

#4

Where are you putting the Sponge jar file on the client? The logs are suggesting Sponge isn’t present on the client side.


#5

I thought that Sponge is server only, does it have to be on the client? It didn’t require it when there were no other mods present.


#6

Yes, it needs to be on the client side also.


#7

It wasn’t always that way… o.O


#8

https://docs.spongepowered.org/stable/en/about/faq.html#id11

Switching to Sponge should not affect players on your server. If you (as a server owner) migrate correctly, players will be able to connect to your server the same way as they did before you migrated to Sponge. They will not need to have Forge installed - unless your server runs Forge mods, of course.


#9

No, it does not. Sponge is only needed on the Server. Running SpongeForge on the client is generally unnecessary, unless you want to run a LAN server or have some special client-side features.


#10

Woah, let’s take a step back here. First, Sponge is not required to be on the client side (though it does have some client features). The entire point of Sponge is to allow servers to make use of mods that are server-side only (plugins) that way player’s don’t have to install client mods on their side. Having it be required on the client would kindof defeat the point, don’t you think?

In relation to your issue, that message is provided when something has been registered on the server that isn’t present on the client or verse-visa. Sponge can’t always be compatible with all mods (there’s quite a number that do some really weird things), so I think it’s likely that this is a mod incompatibility issue.

You said that you’re able to connect if only Sponge is installed, so I suggest adding mods in batches until you experience this error again to narrow down what might be the cause. If at all possible, I would stick to using the recommended SpongeForge version (3002, iirc) as newer ones are ‘less stable’ and have issues with certain mods (note that this is a different Forge version as well). The interactions between mods, especially core mods, can be quite complex and make it difficult to identify the source of a problem. For now, the best I can recommend is some good 'ol trial and error until you have a better idea what combination of mods is causing this. Good luck!


#11

I have tried 3002 and the issue is still persisting.

I’ll check to see if I can solve it that way.


#12

@Inscrutable @Simon_Flash - thanks for the information; I didn’t know the history.

@funniray - You may want to start with MMD OreSpawn. The client log has around 560 error message from the Netty framework concerning the registry for that mod. I’m not certain, but it is worth a try.


#13

UniDict-1.12.2-2.5b.jar was the issue. I’ll report the issue when I get time.

EDIT: It’s a known issue and the devs don’t intend on fixing it.