FlexibleLogin [v0.17] for Sponge 7+ - Auth plugin - 2FA


#346

You may want to change the message “You have to enter two passwords.” to “You have to enter your password twice.” since the way it’s written is very ambiguous.


#347

Forge: 1.12.2-14.23.3.2655
Sponge: 1.12.2-2655-7.1.0-BETA-3065

And my other plugins installed:

ProjectCore
ProjectPortals
ProjectWorlds


#348

See the [nucleus] before the message? That means that the plugin nucleus is the one logging it to the console. You probably need to either tell nucleus not to do it (via a config), or remove nucleus, or maybe a patch can be pushed out via FlexibleLogin.


#349

https://nucleuspowered.org/docs/

Configure the filter: config\nucleus\main.conf

# +------------------------------------------------------------+
# |                       Command Logger                       |
# +------------------------------------------------------------+
command-logger {
    # A comma separated list of commands in the blacklist or whitelist (see whitelist option). Only one alias per command is required.
    command-filter=[
        login,
        register
    ]
    # If any option is true, log commands from the source.
    log-command-source {
        command-block=false
        console=true
        other-source=true
        subject=true
    }
    # If true, will log commands to files at /logs/nucleus/commands
    log-to-file=true
    # If true, the "command-filter" containing the list of commands to be logged is a whitelist (command must be specfied to be logged), not a blacklist.
    whitelist=false
}

#350

Now it works perfect. Thank you very much.