GriefPrevention Official Thread [1.10/1.11/1.12] TOWN/WECUI Support


#1108

chat module was ripped out and hasn't been redon yet, /gamerule doFireTick false to stop fire, if TNT is going off then you need to disable the placing of it


#1109

'/gamerule doFireTick false' Makes it so that fire doesn't go out.


#1110

it also turns off fire spread


#1111

I'm proud to announce a MAJOR update that brings forth a brand new API for GP plugin addons, many bug fixes, new features, and a ton of other changes. This API opens up the doors for plugins to start developing addons for GriefPrevention such as Skyclaims.

IMPORTANT: This release brings forth MANY big fixes, changes, and
features. Most permissions have been changed to make it easier for admins
to manage. When you update to this build, you will need to replace all
'griefprevention.claim.flag' permissions with 'griefprevention.flag'. All
other permissions that have been set for users and admins will probably
have to be re-set. This build also REQUIRES latest SpongeForge build 2022
and higher to work properly.

Changelog can be found here

http://files.minecraftforge.net/maven/me/ryanhamshire/griefprevention/1.10.2-2.3.0.208/griefprevention-1.10.2-2.3.0.208-changelog.txt

Download here

http://files.minecraftforge.net/maven/me/ryanhamshire/griefprevention/1.10.2-2.3.0.214/griefprevention-1.10.2-2.3.0.214.jar

If you have any issues with upgrade or any other questions, please visit my Discord channel here
https://discord.gg/jy4FQDz


#1112

I use this mod/plugin and I like it very much but when I'm trying to make a shop with AdminShop players can't buy anything in a admin claim. I already tried /cf interact-block-secondary minecraft:sign true override but then he says: Invalid target id 'Minecraft:sign' entered for flag interact-block-secondary. so what do i wrong?


#1113

I'll test this when I get home and then get back to you.


#1114

Ran the following:

/cf interact-block-secondary pixelmon:any true override
/cf interact-entity-secondary pixelmon:any true override
/cf interact-item-secondary pixelmon:any true override

While inside my claim (am opped) so that users can use the pc/pokehealers/etc, but whenever someone tries to, they get the message: "You don't have the administrator's permission to use that."


#1115

You are using wrong id, it should be minecraft:wall_sign. Remember you can always use F3 and look at the block for the correct ID.


#1116

Make sure you are using latest GP, SpongeForge, and latest LuckPerms(recommended). Latest PEX should be fine as well but I havent tested.


#1117

Have latest GP and SpongeForge. Running latest PEX. Users also can't claim/unclaim/etc, even though I have:

                    "griefprevention.claim.command.abandon":1,
                    "griefprevention.claim.command.abandon-all":1,
                    "griefprevention.claim.command.abandon-top-level":1,
                    "griefprevention.claim.command.list":1,
                    "griefprevention.claim.command.set-name":1,
                    "griefprevention.claim.command.set-farewell":1,
                    "griefprevention.claim.command.set-greeting":1,
                    "griefprevention.claim.command.subdivide":1,
                    "griefprevention.claim.command.basic-mode":1,
                    "griefprevention.claim.command.info.base":1,
                    "griefprevention.command.player.ignore":1,
                    "griefprevention.command.player.unignore":1,
                    "griefprevention.command.player.list":1,
                    "griefprevention.command.player.unlock-drops":1,
                    "griefprevention.claim.command.trust.access":1,
                    "griefprevention.claim.command.trust.container":1,
                    "griefprevention.claim.command.trust.build":1,
                    "griefprevention.claim.command.trust.list":1,
                    "griefprevention.claim.command.trust.remove":1,

Think my problems began with this version of GP. Was running an old version of GP before and things were working fine (don't recall the version, think was running version 2.2.0.203 then).


#1118

If you used 207, restore GP data prior to that as there was a bug with subdivisions. If you have no subdivisions then it wont matter. Update to 209+ and give your users griefprevention.user as permissions have changed. This is all explained in the changelog which you should always be reading before updating blindly.


#1119

Was going off this: Permissions (WIP) - check GPPermissions984 for a complete list until this is fully updated.
And links to a 404...

Removed all GP data before updating (was making a new world anyway). I'll give users griefprevention.user, although don't see that in changelog, rather see "griefprevention.claim.flag" to "griefprevention.flag".


#1120

Ah yes, I need to update my post badly. Try my wiki https://github.com/MinecraftPortCentral/GriefPrevention/wiki
which is still being worked on.

The best support is in my discord channel here

https://discord.gg/jy4FQDz


#1121

I just used the command it works but they still can not buy anything, if i place a shop outside a claim they can. So any other command that i can try?


#1122

Use /gpdebug playername true
This will tell you what is happening.


#1123

It doesn't show anything


#1124

Try LuckPerms with latest GP build 214


#1125

Is there a way to make all claims have the flags:
/cf projectile-impact-block pixelmon any true
/cf projectile-impact-entity pixelmon any true
/cf entity-spawn pixelmon true

Similarly how all /adminclaims share the same flags? Since pretty sure all users would want that by default in their claims.


#1126

yes, use override


#1127

@blood I don't suppose there is any possible way to convert player or claimdata from bukkit (1.7.10) to sponge 1.10?