📦 HuskyCrates [v1.8.0-PRE2.1] [API 5-7] - Now with GUI Configuration!


Hey just had a crash related to your plugin, using the latest spongeforge 1.10.2 for api 5, husky crates 1.6.0 and huskyui v0.2.1 https://pastebin.com/C0VdLQFs heres the crash report


That's, uh, literally just loading the config. I can't fix this as far as I know, so this might be better reported to SpongeCommon rather than me. It seems to be an issue with Configurate somehow.

It's possible that you were writing to the file at the exact moment that it was saving somehow.


Also, please send me your config.


i will pm you my config


v1.7.0 has been released!

This update addresses issues with crashing during config loading during normal use.
This also moves all of your date over to a H2 Database.
Backup your crap.


Remember, if you’re running a server on those latest builds once the refactor (in the global pin) is merged, chances are a few things won’t work with HuskyCrates. I’ll be making sure to make it work ASAP.


I don’t really know where else to put this, but I’ve noticed when making Statue crates, the text is off-center.


That kind of thing tends to happen when your config errors. We’ll chat about this further on discord.


Just so everyone knows, v1.7.0 does not seem to actually cause issues with loading / saving of data. Please, please back up your configs before updating, but there does not seem to be an issue with the plugin itself.


v1.7.1 for API 5.x-7.0.0 has been released!

This fixes issues with DBs that people have been running into! Please, please update.

Same deal as before. Back up your configs before using this update. This has the conversion functionality still, plus some bugfixes (some of which were in v1.7.0 but might as well say em now)

BACKUP PLEASE and report all issues to my discord before making an issue, unless you know what you’re doing and can make a full report with logs.
huskyui v0.3.0


  • Fixed all data being wiped from the db after using keys
  • Fixed version checking and armor stands not lining up properly (this is still an issue, but was prevented in some cases)
  • Fixed console spam
  • Fixed item-specific lang overrides
  • Possibly fixed some issues related to filesystems using different slashes


  • Now using H2 databases

thank god for bug reports am i rite


Have noticed something

Lets say there are 3 items in a crate: Dirt,Stone,Diamond

The Diamond ends up being the item between the redstone torches the user will either get an Stone or dirt block instead of the Diamond

are you able to fix this?


I’d need a config or something because I’ve never experienced this.


i’l send you the config :slight_smile:



Which crate has the issue


all off em lol me and my staff have been looking how to fix this ourselfs whitout luck we tried it with changing the speed and so on


… no, which crate has the example you provided?

Just because I don’t show the last frame of the spinner animation doesn’t mean it doesn’t click once more.


as example Epic crate it mostly ticks 2 times then the Diamond is between the redstone torches but the user still gets Dirt or Stone instead of the Diamond i gotta tell you i am using pixelmon items in it


I have no idea what you’re referring to. A recording or something would be nice.


i’l try to do that when i am on the server :slight_smile:


I’m curious about how much people want this feature, so…

  • I want custom DB url support (e.g. support for MYSQL)
  • I don’t care if that is added or not

0 voters