Is there a version of sponge that would work with 14.23.2.2651?


#1

I’m starting a sevtech server for me and some friends but I can’t get sponge to work, Is there a version I could use or will I have to wait for a update?


#2

Whats the error you get?
(Im a vanilla guy myself but I have seen that sponge forge is normally forward compatible. It could be that your sponge doesnt like a forge mod)


#3

This is what console says:

10:16:20 PM CONSOLE: [Sponge]: /**************************************************************************************************************************************/
10:16:20 PM CONSOLE: [Sponge]: /* /
10:16:20 PM CONSOLE: [Sponge]: /
Oh dear. It seems like this version of Sponge is not compatible with the version /
10:16:20 PM CONSOLE: [Sponge]: /
of Forge you are running. /
10:16:20 PM CONSOLE: [Sponge]: /
/
10:16:20 PM CONSOLE: [Sponge]: /
------------------------------------------------------------------------------------------------------------------------------------/
10:16:20 PM CONSOLE: [Sponge]: /
/
10:16:20 PM CONSOLE: [Sponge]: /
A error was encountered whilst patching: /
10:16:20 PM CONSOLE: [Sponge]: /
/
10:16:20 PM CONSOLE: [Sponge]: /
One or more Sponge patches could not be applied whilst loading Sponge, this is /
10:16:20 PM CONSOLE: [Sponge]: /
a permanent error and you must either: /
10:16:20 PM CONSOLE: [Sponge]: /
/
10:16:20 PM CONSOLE: [Sponge]: /
* Use the correct build of Forge for this version of Sponge (14.23.2.2611) /
10:16:20 PM CONSOLE: [Sponge]: /
/
10:16:20 PM CONSOLE: [Sponge]: /
* Use a version of Sponge for built for your version of Forge /
10:16:20 PM CONSOLE: [Sponge]: /
/
10:16:20 PM CONSOLE: [Sponge]: /
The patch which failed requires Forge build: 14.23.2.2611 /
10:16:20 PM CONSOLE: [Sponge]: /
but you are running build: 14.23.2.2651 /
10:16:20 PM CONSOLE: [Sponge]: /
*/


#4

As far as I am aware, there is no official build for 2651. I might be mistaken however. Sometimes versions of Sponge are slightly forward and backwards compatible, but for best results use the exact version of Forge that Sponge requires.

Also in the future if someone asks you to post errors or whatnot, please post you latest.log into a service like pastebin or gist, and then provide a link here.

Good-luck!