πŸ”‘ PermissionManager [v3.0.1] [API 5.X] A simple and easy permission plugin


#609

Hi there, I was just wondering if you have gotten any further along with the GriefPrevention fix? I really like the ease of use about this plugin and don't want to give it up to get this to work :frowning:


#610

I'm currently working on it, but I can't tell when it will be ready.


#611

Please do let me know if there's a workaround for it!


#612

May I ask why the plugin creates groups named default-(numbers) upon every restart and changes it to default?


#613

If the server doesn't have any default group, it will create one with the name default-(numbers)


#614

I set my default group (Trainer) everytime after it does this


#615

How do you set your default group?


#616

Through the menu.
/pm -> Groups -> Default Group: default-numbers and chose Trainer. Then saved it.


#617

Do you have the permission permissionmanager.commands.groups.set.default?


#618

I can confirm that this is also an issue for me. I create a different default group using the In-Game command and then delete the pre-made default group. after a restart it will restore the group and reset the default to that.

If i do not delete the pre=made group and just change the default group, everything will be fine and it will keep the default group that i have set it to


#619

I will check that issue tonight. I will test it like you said @leelawd93.


#620

I'm having the wildcard permission. Do I really need that permission @djxy?


#621

* is the permission to have access to all the permissions.


#622

My point is that since I'm having the * node, I don't need permissionmanager.commands.groups.set.default
However I'll run some tests about when default groups are made on their own and let you know. Who knows it might be a bug or some problem from my side


#623

Today I tested and everything was fine. I will test it like @leelawd93 said before.


#624

I tested with PermissionManager 2.4.0 and everything was fine. The server didn't had any file from PermissionManager.

I did this:
- Started the server.
- /pm
- Created a new group from the menu.
- Changed the default group to the new one.
- Stopped the server.
- Restarted the server.
- The default group was the good one.

@ChaudBlaze @leelawd93


#625

hi i try to make AdventureMMO rule permission like 30 minning to use minning skill but i cant do it and also i need to add cooldown to use skills here my groups yml i hope you reply me and thanks for everythink :slight_smile:

options:
prefix: '&6Kâylü'
rules:
permission.manager:
adventuremmo:
skills:
mining: 20
farming: 15
woodcutting: 30


#626

Can you use pastebin please? I will be easier for me.

Edit: Also, what is the permission you want to add the rule.


#627

http://pastebin.com/308b5jhr

you know adventuremmo like using skills i want to people use these skill at 30 lvl and also i want to people use these skills not unlimited like every 5 min you can use


#628

You can restrict the use of Γ  permission with Adventuremmo. You have to find the permission to restrict and follow the example on the wiki. I can also help you, but I won't search the permissions for you.