Pieconomy - An economy plugin that uses items as currency


#62

Thanks, it works with nations. Could you add the ability to exchange currency down, for someone like me who will disable the /pay command and make it so people can only trade through shops and the trade mod for forge?


#63

Actually it doesn’t work with nations, the problem is the same


#64

I did not envision this plugin being used with direct trading. I could definitely change the /exchange command to go downwards as well as upwards.
As for it still not working - that’s interesting, could you post your config?


#65

my config is the default


#66

That would explain it, because it comes disabled by default. See the project page for how to configure dynamic accounts.


#67

Actually, linking multiple currencies its a great idea, like @steelropes said.

I’ve think also in the iron - gold - emerald currency configuration, but didnt know how to configure the plugin to set that 100 iron = 1 gold and 100 gold = 1 emerald.


#68

You would pick a name for a singular currency, and then make iron worth 1, gold worth 100, and emerald worth 10,000.


#69

Such a great plugin. But can i use IC2 coin as currency?
Screenshot_2%5B1%5D

If i set it in my config file like:
“ic2:crafting 38” {
currency = gold
amount = 1
}

or

“ic2:crafting 1 38” {
currency = gold
amount = 1
}

plugin just stops working. At the same time i can use it like

“ic2:crafting” {
currency = gold
amount = 1
}

So i can use rubber as currency. Can you give me some advices?


#70

I can give you the advice of reading the plugin page.


#71

Sorry for taking your time.
Love you. You made BC2 coin usefull.


#72

Edit. Literally the post above mine answered my question.

I really got to read more.


#73

Sorry for the double post… Gonna get scorned for it I’m sure, Just want to ensure you see it…

I do actually seem to be having an issue with the above instructions, or it could be the forge mod itself.

I’m getting a no value present when I issue any command with a reference to the forge mod’s currency in the config.

Here’s the error from the console: https://pastebin.com/ZXybx1ds

Here is the config I want to see work: https://pastebin.com/SC08ztrR

Here is that link to the mod: https://minecraft.curseforge.com/projects/good-ol-currency

The dev of that mod states that his mod was poorly coded so and is intending to come back for a rewrite so… I wouldn’t be surprised it the issue is on the mod’s side. I just would love to make it all work well…

Let me know when you have a second what you think! I appreciate it.


#74

Can I get a full server log? I’m pretty sure it’s not the mod’s fault, that’s erroring on finding a currency by ID.


#75

here is the latest.log https://pastebin.com/V8A4r05D


#76

It’s saying, essentially, that the currency doesn’t exist.
Which makes me go because there’s no errors with the currency registry.

Can you try (on a fresh server, so it doesn’t corrupt a world, obv) removing each mod one by one and re-adding afterwards until it no longer breaks? Because that way I’ll at least know where to look.


#77

Lemme try building a local server with just those two mods and see if the issue still exists. If it does, should be pretty isolated for ya.


#78

Here is the latest and debug log for you. I hope you don’t mind this method of getting the logs to ya. The debug log exceeded pastebin’s sizes as one would guess. I felt this might help you zero into what might be causing this.

I copied configs and such directly from the other server. The only thing I stripped was the other mods and the world.

https://emberpixelmon.com/logs/pieconomy


#79

Well, a status update is that despite the registry giving the currency when asking for all currencies, it does not give the currency when asking for it by ID, even if you get the ID directly from the currency retrieved by asking for all currencies. So that’s almost definitely a Sponge bug.
If this doesn’t get fixed in two or three days I’ll release a hotfix which will be an ugly hack with slower lookup times but will technically work.


#80

Alright. I believe my sponge version is slightly out of date as well so I’ll go ahead and upgrade and watch for that bug fix. I appreciate it!

Just as an update, latest stable build doesn’t have the fix, or at least it presents me with the same error.


#81

Pie, have you heard of any news concerning this issue?