Problem with Mo'Creatures and Sponge


#1

I’ve an assembly of mods that includes the Mo’Creatures mod on version 1.12.2. Have a Sponge server 1.12.2-2655-7.1.0-BETA-3065. Everything works fine until I kill a mob from Mo’Creatures. Loot falls, I take it and disconnect from the server (internal server error). But disconnection is not immediate, sometimes you need to kill 3-5 mobs, sometimes disconnected after 10. Not all mobs lead to server crash. I noticed a problem with werewolf and wild wolf.

As I understand the error in the stack of items:
at net.minecraft.entity.item.EntityItem.redirect$onAddItemStackToInventory$zfm000(EntityItem.java:778) ~[acl.class:?]
[Server thread/WARN] [net.minecraft.network.NetworkSystem]: Failed to handle packet for /127.0.0.1:53494
net.minecraft.util.ReportedException: Adding item to inventory

But I can be wrong. Nothing crash reports and server crash itself. The problem is only with Mo’Creatures other mobs from other mods work fine. After disconnection i can’t enter on the server. Helps only new generation of the world.


#2

We need full logs (via pastebin or gist); that one line does not actually help.


#4

I apologize, but the error extends to other mobs too. It looks as if the error occurs when I pick up loot. Recorded all server messages from logging on to the server and until an error occurred.

[01:11:58] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer]: Zombyai joined the game
[01:12:22] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer]: [Zombyai: Set own game mode to Creative Mode]
[01:12:47] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer]: [Zombyai: Set the time to 42000]
[01:13:11] [Server thread/WARN] [net.minecraft.network.NetworkSystem]: Failed to handle packet for /127.0.0.1:54075
net.minecraft.util.ReportedException: Adding item to inventory
at net.minecraft.entity.player.EntityPlayerMP.func_71127_g(EntityPlayerMP.java:459) ~[oq.class:?]
at net.minecraft.network.NetHandlerPlayServer.redirect$onPlayerTick$zil000(NetHandlerPlayServer.java:2036) ~[pa.class:?]
at net.minecraft.network.NetHandlerPlayServer.func_73660_a(NetHandlerPlayServer.java:173) ~[pa.class:?]
at net.minecraftforge.fml.common.network.handshake.NetworkDispatcher$1.func_73660_a(NetworkDispatcher.java:209) ~[NetworkDispatcher$1.class:?]
at net.minecraft.network.NetworkManager.func_74428_b(NetworkManager.java:285) ~[gw.class:?]
at net.minecraft.network.NetworkSystem.func_151269_c(NetworkSystem.java:180) [oz.class:?]
at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:788) [MinecraftServer.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:396) [nz.class:?]
at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:666) [MinecraftServer.class:?]
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:524) [MinecraftServer.class:?]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_131]
Caused by: java.util.NoSuchElementException: No value present
at java.util.Optional.get(Optional.java:135) ~[?:1.8.0_131]
at net.minecraft.entity.player.InventoryPlayer.getSpongeSlot(InventoryPlayer.java:1741) ~[aec.class:?]
at net.minecraft.entity.player.InventoryPlayer.redirect$onAdd$zgo000(InventoryPlayer.java:1760) ~[aec.class:?]
at net.minecraft.entity.player.InventoryPlayer.func_70452_e(InventoryPlayer.java:284) ~[aec.class:?]
at net.minecraft.entity.player.InventoryPlayer.func_191971_c(InventoryPlayer.java:425) ~[aec.class:?]
at net.minecraft.entity.player.InventoryPlayer.func_70441_a(InventoryPlayer.java:378) ~[aec.class:?]
at net.minecraft.entity.item.EntityItem.redirect$onAddItemStackToInventory$zfm000(EntityItem.java:778) ~[acl.class:?]
at net.minecraft.entity.item.EntityItem.func_70100_b_(EntityItem.java:400) ~[acl.class:?]
at net.minecraft.entity.player.EntityPlayer.redirect$onPlayerCollideEntity$zgm000(EntityPlayer.java:3700) ~[aed.class:?]
at net.minecraft.entity.player.EntityPlayer.func_71044_o(EntityPlayer.java:600) ~[aed.class:?]
at net.minecraft.entity.player.EntityPlayer.func_70636_d(EntityPlayer.java:571) ~[aed.class:?]
at net.minecraft.entity.EntityLivingBase.func_70071_h_(EntityLivingBase.java:2170) ~[vp.class:?]
at net.minecraft.entity.player.EntityPlayer.func_70071_h_(EntityPlayer.java:234) ~[aed.class:?]
at net.minecraft.entity.player.EntityPlayerMP.func_71127_g(EntityPlayerMP.java:382) ~[oq.class:?]
… 10 more
[01:13:11] [Server thread/INFO] [net.minecraft.network.NetHandlerPlayServer]: Zombyai lost connection: Internal server error
[01:13:11] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer]: Zombyai left the game

This is what happens when you try to reconnect to the server after an error. Full list of mods on client included

[04:41:35] [Netty Server IO #2/INFO] [FML]: Client protocol version 2
[04:41:35] [Netty Server IO #2/INFO] [FML]: Client attempting to join with 77 mods : ctgui@1.0.0,astralsorcery@1.8.8,netherportalfix@5.3.13,creativecoredummy@1.0.0,ebwizardry@4.1.1,jei@4.9.0.163,multihotbar@1.12.2-4.0.1-build-T116,mtrm@1.2.2.30,chunkpregenerator@1.8,nei@2.4.1,bibliocraft@2.4.3,ivtoolkit@1.3.3-1.12,lttweaker@1.1.14,md@1.12.2,mcp@9.42,ctm@MC1.12-0.2.3.12,journeymap@1.12.2-5.5.2,notenoughwands@1.6.1,nex@2.1.14.15,chameleon@1.12-4.1.3,inventorytweaks@1.63+release.109.220f184,xreliquary@1.12.2-1.3.4.760,harvestcraft@1.12.2t,foamfixcore@7.7.4,waila@1.8.24,inventorypets@1.4.9.9b,crafttweaker@4.1.6,enderstorage@2.4.2.126,jeresources@0.8.5.27,thaumcraft@6.1.BETA13,mcjtylib_ng@2.6.7,forge@14.23.3.2655,twilightforest@3.6.345,multihotbarcore@1.12.2-1.0.1-build-T22,dsurround@3.4.7.2,infernalmobs@1.7.5,ironchest@1.12.2-7.0.40.824,minecraft@1.12.2,subterranaenwaters@1.12.2-1.0,crafttweakerjei@2.0.0,mtlib@3.0.4,biomesoplenty@7.0.1.2361,baubles@1.5.2,blur@1.0.4-14,creativecore@1.9.9,reccomplex@1.4.7,modtweaker@4.0.11,customspawner@3.11.4,littletilescore@1.0.0,mocreatures@12.0.4,betterunderground@1.1.5,loottweaker@0.0.7,mantle@1.12-1.3.2.24,abyssalcraft@1.9.4.9,gravestone@1.10.1,lightorbs@1.0,morepaintings@$version,FML@8.0.99.99,worldeditcuife2@2.1.2-mf-1.12-14.21.1.2387,worldedit@6.1.8,embers@0.230,chisel@MC1.12.2-0.2.0.31,moreoverlays@1.13,recipehandler@0.10,foamfix@0.9.9-1.12.2,itemscroller@0.11.0,aether_legacy@1.12.2-v3.0,aquaculture@1.6.1,presets@3.4.7.2,cavern@2.1.5,codechickenlib@3.1.6.339,fastleafdecay@v14,dynamictrees@1.12.2-0.7.6,torohealthmod@1.12.2-11,betterfoliage@2.1.10,littletiles@1.5.0,betteradvancements@0.0.5.17
[04:41:35] [Netty Server IO #2/INFO] [FML]: Attempting connection with missing mods [spongeapi, sponge, fastasyncworldedit, voxelsniper] at CLIENT
[04:41:37] [Server thread/INFO] [FML]: [Server thread] Server side modded connection established
[04:41:37] [Server thread/INFO] [net.minecraft.server.management.PlayerList]: Zombyai[/127.0.0.1:55372] logged in with entity id 18063 in world(0) at (201.92583668890774, 64.53584062504456, 256.70950409939815)
[04:41:37] [Server thread/INFO] [ebwizardry]: Synchronising spell glyph data for Zombyai
[04:41:37] [Server thread/INFO] [ebwizardry]: Synchronising config settings for Zombyai
[04:41:37] [Server thread/INFO] [Astral Sorcery]: [AstralSorcery] Synchronizing configuration to Zombyai
[04:41:37] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer]: Zombyai joined the game
[04:41:37] [Server thread/WARN] [net.minecraft.network.NetworkSystem]: Failed to handle packet for /127.0.0.1:55372
net.minecraft.util.ReportedException: Adding item to inventory
at net.minecraft.entity.player.EntityPlayerMP.func_71127_g(EntityPlayerMP.java:459) ~[oq.class:?]
at net.minecraft.network.NetHandlerPlayServer.redirect$onPlayerTick$zil000(NetHandlerPlayServer.java:2036) ~[pa.class:?]
at net.minecraft.network.NetHandlerPlayServer.func_73660_a(NetHandlerPlayServer.java:173) ~[pa.class:?]
at net.minecraftforge.fml.common.network.handshake.NetworkDispatcher$1.func_73660_a(NetworkDispatcher.java:209) ~[NetworkDispatcher$1.class:?]
at net.minecraft.network.NetworkManager.func_74428_b(NetworkManager.java:285) ~[gw.class:?]
at net.minecraft.network.NetworkSystem.func_151269_c(NetworkSystem.java:180) [oz.class:?]
at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:788) [MinecraftServer.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:396) [nz.class:?]
at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:666) [MinecraftServer.class:?]
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:524) [MinecraftServer.class:?]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_131]
Caused by: java.util.NoSuchElementException: No value present
at java.util.Optional.get(Optional.java:135) ~[?:1.8.0_131]
at net.minecraft.entity.player.InventoryPlayer.getSpongeSlot(InventoryPlayer.java:1741) ~[aec.class:?]
at net.minecraft.entity.player.InventoryPlayer.redirect$onAdd$zgo000(InventoryPlayer.java:1760) ~[aec.class:?]
at net.minecraft.entity.player.InventoryPlayer.func_70452_e(InventoryPlayer.java:284) ~[aec.class:?]
at net.minecraft.entity.player.InventoryPlayer.func_191971_c(InventoryPlayer.java:425) ~[aec.class:?]
at net.minecraft.entity.player.InventoryPlayer.func_70441_a(InventoryPlayer.java:378) ~[aec.class:?]
at net.minecraft.entity.item.EntityItem.redirect$onAddItemStackToInventory$zfm000(EntityItem.java:778) ~[acl.class:?]
at net.minecraft.entity.item.EntityItem.func_70100_b_(EntityItem.java:400) ~[acl.class:?]
at net.minecraft.entity.player.EntityPlayer.redirect$onPlayerCollideEntity$zgm000(EntityPlayer.java:3700) ~[aed.class:?]
at net.minecraft.entity.player.EntityPlayer.func_71044_o(EntityPlayer.java:600) ~[aed.class:?]
at net.minecraft.entity.player.EntityPlayer.func_70636_d(EntityPlayer.java:571) ~[aed.class:?]
at net.minecraft.entity.EntityLivingBase.func_70071_h_(EntityLivingBase.java:2170) ~[vp.class:?]
at net.minecraft.entity.player.EntityPlayer.func_70071_h_(EntityPlayer.java:234) ~[aed.class:?]
at net.minecraft.entity.player.EntityPlayerMP.func_71127_g(EntityPlayerMP.java:382) ~[oq.class:?]
… 10 more
[04:41:39] [Server thread/INFO] [net.minecraft.network.NetHandlerPlayServer]: Zombyai lost connection: Internal server error
[04:41:39] [Server thread/INFO] [net.minecraft.server.dedicated.DedicatedServer]: Zombyai left the game