The error you have there: net.minecraftforge.fml.common.MissingModsException: Mod bitdrawers (Drawers & Bits) requires [Forge@[18.104.22.1681,)]
Is stating that the version of forge you have is before version 22.214.171.1241
The forge version you are using is Forge 126.96.36.1992
The way to read the mod version requirements is
[Forge@[188.8.131.521,)] is an
[array] of mod requirements. Drawers and bits requires Forge@versionRange.
The versionRange required is [184.108.40.2061,)
This follows mathematic ranges. https://en.wikipedia.org/wiki/Bracket_(mathematics)#Intervals
e.g. The notation [a,c) is used to indicate an interval from a to c that is inclusive of
a but exclusive of
So that mod needs 220.127.116.111 or higher version of forge.
I can’t speak for errors you havn’t shown, but generally I would just be running the latest forge for 1.10 with the latest spongeForge for 1.10 with the latest version of the mod pack you are using and go from there.