[SOLVED] Hopper doesn't seem to take or put an item in the chest but still vacuum dropped item



I have an issue with Sponge. The hopper doesn’t seem to take or put an item in the chest, but can still vacuum item when I throw one on the top.

This is the test scenario :

I think I miss a tweak in the configuration, but I can’t find anything. I try to disabled all plugin (LuckPerm, Nucleus, GriefPrevention), the problem is still here when I launch Sponge (I use : spongevanilla-1.12.2-7.0.0-BETA-370.jar)

But if I launch it in vanilla (with the minecraft_server), hopper work well !

Thank in advance for your help !




I think this video will help you to understand my issue with the scenario vacuum + put in chest :

In doubt, I tried that in a fresh local server with nothing else on it and I still have the issue (with BETA-370 and BETA-371 unfortunately). Hopper work fine with just the minecraft_server.jar

Tested both on Debian and WIndows 10 - Java 8


fixed in latest


Tested myself too, all work now.

Thank for your fast fix !