SpongeBootstrap - Fixes ordering issue with other coremods


That launch was without bootstrap


When i try launching with Bootstrap, Following the proper instructions I get this error

25.04 19:02:03 [Server] main/INFO Detecting environment...
25.04 19:02:03 [Server] main/INFO Found launch wrapper, continuing
25.04 19:02:03 [Server] INFO An error occured when listing directory contents
25.04 19:02:03 [Multicraft] Server shut down (starting)


Do you have all the library's? Run the ftb beyond on your own computer first. Let it download all the library's and copy them to your host.


Hmm I'm not too sure what could be causing that. It's possible that the Java process used to run the bootstrap doesn't have permission to list the server directory. Or somehow the bootstrap jar is not inside a regular directory.

Instead of using the bootstrap, you could replace Applied Energistics 2 with one patched for sponge compatibility. (There is an incompatibility with sponge and AE2).
You can get the patched AE2 from here:


I pulled all the library files from a fresh forge install itself


The way multicraft works on my server is it requires all server launch jars to be in a jar folder, would that be causing that error, if so would there be anything on my end i could do to fix it


Don't let the file names fool you. The patched file name is the same as the original. I thought I had the correct one, but everything started working when I uploaded the patched file to my server.


Version 0.4.0 released to support Minecraft 1.12.


Version 0.5.0 fixes issues with recent forge versions on 1.12 and adds support for Minecraft 1.12.1.


Is this project still being worked on? If so I have a lovely crash report for you :slight_smile: Can supply mods and more info if needed.

mc: 1.12.2
Forge: 1.12.2-
Spongeforge: 1.12.2-2555-7.0.0-BETA-2760
Bootstrap: 0.6.0


Edit: tried to launch without the boot strap and find that all the boot strap really does is help the server crash faster/not freeze up before crashing (same reasons)


There seems to be an issue with the mod “Gotta Go Fast”. It’s interesting that bootstrap was not able to avoid the issue, I’ll see whether it can be fixed with bootstrap.

For now, remove the mod and that should fix it.


Alright Thank you! Also you just saved me from 145 mod roulette to see what mod it was XD