SpongePls [BungeeCord Forge Support]


This is 1.8 as Sponge is 1.8+


When trying to join a 1.8.9 Forge server from the lobby.

23.03 20:55:34 [Server] INFO [SpongePls] Using the Forge Server Connector for OvP
23.03 20:55:34 [Server] INFO [SpongePls]  for the target "Pixelmon".
23.03 20:55:48 [Server] INFO [SpongePls] Using the Forge Server Connector for OvP
23.03 20:55:48 [Server] INFO [SpongePls]  for the target "Pixelmon".
23.03 20:55:51 [Server] INFO [SpongePls] Using the Forge Server Connector for OvP
23.03 20:55:51 [Server] INFO [SpongePls]  for the target "Pixelmon".

I'm doing /server Pixelmon and nothing seems to work.


@Txk that might be Pixelmon, not too sure.

@Tzk thanks for that.

Just a note to everyone, a much more light weight alternative is available by @dualspiral. <-- He's also more active than me on here.


23.05 01:48:08 [Server] INFO for the target "Pixelmon".
23.05 01:48:08 [Server] INFO Using the Forge Server Connector for FrostEffects
23.05 01:47:19 [Server] INFO at java.lang.Thread.run(Thread.java:745)
23.05 01:47:19 [Server] INFO at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:112)
23.05 01:47:19 [Server] INFO at io.netty.channel.epoll.EpollEventLoop.run(EpollEventLoop.java:255)
23.05 01:47:19 [Server] INFO at io.netty.channel.epoll.EpollEventLoop.processReady(EpollEventLoop.java:339)
23.05 01:47:19 [Server] INFO at io.netty.channel.epoll.EpollDatagramChannel$EpollDatagramChannelUnsafe.epollInReady(EpollDatagramChannel.java:594)
23.05 01:47:19 [Server] INFO at io.netty.channel.DefaultChannelPipeline.fireChannelRead(DefaultChannelPipeline.java:846)
23.05 01:47:19 [Server] INFO at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(AbstractChannelHandlerContext.java:304)
23.05 01:47:19 [Server] INFO at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:318)
23.05 01:47:19 [Server] INFO at io.netty.channel.SimpleChannelInboundHandler.channelRead(SimpleChannelInboundHandler.java:105)
23.05 01:47:19 [Server] INFO at net.md_5.bungee.query.QueryHandler.channelRead0(QueryHandler.java:20)
23.05 01:47:19 [Server] INFO at net.md_5.bungee.query.QueryHandler.channelRead0(QueryHandler.java:82)
23.05 01:47:19 [Server] INFO java.lang.IllegalStateException: No session!
23.05 01:47:19 [Server] INFO WARNING: An exceptionCaught() event was fired, and it reached at the tail of the pipeline. It usually means the last handler in the pipeline did not handle the exception.
23.05 01:47:19 [Server] SEVERE May 23, 2016 1:47:19 AM io.netty.channel.DefaultChannelPipeline$TailContext exceptionCaught

to expand on @Txk issue. I've also came across this with Pixelmon. It wasn;'t doing this before though. just recently started.


Any news on the connection to Pixelmon?


Working perfect on my pixelmon server. So much love you to :smiley:


Why on try to enter on bungee lobby i always get this:

IP Forwad is "true" on bungee configs.
I put the plugin on Bungee plugin folder;
The lobby is a Spigot server;
The Sponge server is Forge 1902 & Sponge 1.8.9;


Make sure Bungee module is enabled in the Sponge global config as well.


Okay so I start from scratch using the very latest builds of bungee. I just Spigot 1.8.8 as my hub server and I try to use IP forwarding. I got bungeecord to work fine with my hub which I was happy about. Then I try to bring my existing Pixelmon server into this network. As soon as I use this plugin it just locks up my hub saying "If you wish to use IP forwarding, please enable in your BungeeCord config as well!

This is getting quite annoying and I would love some help from someone or to know if this is some type of bug that can be resolved.


This work perfectly for me. Feel free to PM me on pixelmon discord, Isi renamed me to SpreadSheetGuy on there and I can try and help you out. Sounds like your hub server dosn't have bungee enabled in the spigot.yml


If I'm not mistaken, SpongePls has it's config, and because your hub is Spigot, you would need to make sure it is NOT in the allowed-servers list.


is there an example to this config, i am getting kicked from the server for not having forge when i do


oh man, nice work, i'm using it and it's sooo good :smiley:


I solved this problem renaming the server name on plugins/SpongePls/config.yml to lowercase!

This works:

  - 'z12mon'

and this dont work:

  - 'Z12mon'

Its a simple detail that solved my problens!

*And shure, enable bungeecoord module and ip forward on Sponge configuration on Pixelmon server.


Hey there, this is going to be a stupid question, but I really don't understand the config at all.

I've tried adding what I thought to be the correct information, but I still can't connect to my server - Any ideas?


Make sure to enable both Bungee modules and ip-forwarding in the Sponge config


I have done that already, was the first bit of documentation I read :slight_smile: As for the SpongePls config.yml in the Bungee Folder, what am I actually meant to enter in there? The default config is :

- '.*'
- 'ServerNameHere'
- '(.nomatch.)'
- 'CaseInsensaTiVe'

And I have absolutely no idea as to the formatting, or what I'm even meant to enter in there. My apologies for being a bit thick


No worries I had the same issue, so what you put in that config is only the Sponge servers you want and leave out all the Spigot/Bukkit servers


Ok, but in what format?

Say for example, I'm setting up HermitPack - In my Bungee's config.yml, it's Called Hermit, or hermit.mydns.whatever, and has a port of or whatever - How would I input that information into the SpongePls config in a format that works? I can't find any blatent way, sorry for being thick D:


You just put in the name of the Sponge server you have defined in your BungeeCord config so if your Sponge server is called Hermit and you would use /server Hermit to connect to it, just put - 'Hermit'