Teslacrate placeholder deletes himself?


#1

hello
i have a little problem with teslacrate: as i put the placeholder in my commands.conf file and after a restart it deletes himself and i save him before i do a restart.
i talked already with Simon_Flash but he doesnt know too…

here’s my commands.conf file before and after a restart
commands.conf

and here are my plugins:
plugins

can anyone help me because i cant use my crate that i make with the plugin…

greetings
Chazzie


#2

Try adding

testKey = "Bla <player> Bla"
testKey2 = "Bla <abc> Bla"

between one of the curly brackets, change one of the existing <player> to <abc> and report what happens.


#3

ok i tried to add it in my commands.conf but it still deletes himself while i save it first…

its still get to this…

command=“pokegive random level:20 s”


#4

I mean something like this: https://pastebin.com/nW21g0Yn


#5

still deleting himself and no errors in console…

command=“pokegive random level:20 s”
test1=“Bla Bla”

i tried to delete some plugins and that didnt help


#6

Please post the config before and after loading it, like in your first post.


#7

this is it.
commands.conf

its still deleting himself…


#8

and i tried to use the supported sponge version but that didnt work…


#9

Maybe that’s a feature of HOCON/configurate? My last guess would be escaping all < and > to \< and \>.

@Simon_Flash


#10

I’ve been around the block with this issue on Discord a couple times, and ultimately I don’t have a solution. It’s certainly not something with Configurate (it’s not in the spec, nor can I replicate it), and it’s not TeslaCrate (it’s replacing values in nodes that aren’t accessed and saving a file that isn’t saved by TeslaCrate). Trying to escape them is a good idea and might do the trick.

My working theory is that this is being caused (or at least related) to the host’s file system. I’m not exactly sure what (or why) there would be anything here that could cause this, but at the end of the day options are rather limited. I think there might be some merit to the file encoding (as it appeared that there were differences in whitespace characters present), however this should not affect the default configuration as they’ll all made in the same way.

At this point, the best I can suggest is to test things wherever you can. See if angle brackets in comments are removed, and whether this affects multiple files (both within and outside of TeslaCrate), a single file (try renaming), or a file with a specific name (or loading order). If you can, try a different server and see if you have the same issue, and whether this only occurs for servers on that host. There’s not much I can really do about it, and I can definitively say that TeslaCrate isn’t the cause of this.


#11

What OS is this running on? Is it self hosted, or are you using a company?


#12

im using a company named nitrous-networks and i asked them already