🏆 AdventureMMO [v2.0.7] [API 4/5/6]


I tested sponge 7.1.0 on 1.12.2
I didn’t run into that issue when leveling up, but I’ll look into it.
Is it consistently giving the error when leveling up?


It is, I did further testing and here is what I am seeing.

If I log in and play and no skills are raised by AdventureMMO, everything appears to work fine. Including saving.
I can log in and out of the game without issue.

The second I raise a skill in AdventureMMO, all other saving breaks. AdventureMMO skill changes are saved, so if I raise Unarmed from 0 to 5 for example, that will be saved. But anything else will not. All blocks, and changes that have happened since the first AdventureMMO skill raise will be gone. As soon as I log out the entire server will crash. When I log back in, and check “/skills” I will see Unarmed at 5, but all the rest of Minecraft changes such as items I have picked up will be gone.

This is readily reproducible on my system as it happens every single time. Here, I went ahead and did a screen capture of the issue. This shows making changes, logging out and in and showing them save without issue. Then it shows digging until the farming skill raises 1, saving breaks, and all changes made after the skill raised are lost. Server crashes on log out. Video showing the issue.


Thank you very much for more info and a video. I’m looking into it now

Edit: Fixed
Linked removed by forum staff.


Did quick initial pass over the fix and its working good. :smiley:

If we encounter anything else as we use the plugin more I will post them directly as issues on github. Thanks once again for doing this work Rojo, and for the super quick turnaround time on the fix.


Why were @rojo8399’s revisions removed?


The original plugin I forked off of doesn’t have any license. So it’s protected by copyright and I don’t have legal authority to distribute my fork.

You can help out with this by bugging Daniel about this pull request :stuck_out_tongue:https://github.com/Daniel12321/AdventureMMO/pull/56


I’ve done my part, hopefully he replies.


hello im a noob in need, i realy want to play this on a server i made for me and my friends but i dont seem to know how to install it. i figured i would just drag and drop the .jar file into mods but it dosnt seem to work. so far i have tried 6 different file then booting up the game in single player and it wont work in single player either, no acsess to menus or anything. what should i do?


i forgot to mention i have tried with all of my mods and also with no other mods and the version im playing on is 1.12.2


This project has long been abandoned and the original Author has not made a licence to allow anyone else to continue it, and despite these awesome people’s efforts, it doesn’t look like he’s going to show up to add one :confused:


You have to install first:
To recognize the plugins in the Mods folder.


It’s incompatible with modern versions.


thank you everyone for all the quick responses, i cant get it to work so ill just use lvl up instead.


What is lvl up and can you like in? I’m having a hell of a time finding an RPG plugin for my server…




if anyone knows any mods like mcmmo, im interested.


Just wanted to let people know I’m looking into creating this plugin again.
We’ve tried to gain copyright access, but had no luck.

I’ll watch for any feature requests on this forum.


I am interested in either an update to this plugin, or an all new RPG like plugin


Thx ! I’m not a dev but if i can help…


Do different animals give different point values for swords, archery, and axes?