Universe Guard 2: an easy to use world protection plugin


#22

Ohh GOD! Very, very GoodJob MAN.


#23

VERSION 2.2 RELEASED!

Download it here > https://goo.gl/WBZJ7A

Changelog:

  • New command: /rg here - Tells you if you in wich region you are
  • New flag: hideregion - If you are in a Region with this flag set to true, doing the /rg here command will not tell you

Bug fixed:

  • Players can still see a flag value of a Region with the hideflags set to true using the /rg flaginfo command
  • If an interact is set to false in a Global Region it says “You don’t have a permission” even if you are OP

Updates on API7:
The API7 project is almost done, fortunately only a few classes that the actual code (API6) uses are gone (like ItemEnchantment or EntitySpawnCause). I plan to release a first API7 version next week, if all tests goes good.
Stay tuned for more updates and please let me know your thought, suggestions or if you find some bugs :slight_smile:


#24

Sorry, because after upgrading “Universe Guard 2” my world is overwhelmed monsters. Can you add “mob-spawning” flags and “keep-inventory” flags?

  • I really do not know much about minecraft and mods. Because when I use the / butcher command from wedit all the minecraft default monsters will be removed but some monsters from the mod will not be affected. And is there a way to use the monster blocking flag from birth? Since I’m trying to create an RPG server and the monsters I created from CustomNPCs and I just want the monsters from CustomNPCs to be allowed to exist in the world.

  • I do not know if this is a bug or if I do something wrong, when I use the command “/ gamerule domobspawning false” the monster could not be created but when closing the server and reopening everything back to default. It happens on bukkit, spigot and spongot.


#25

For “Keep-inventory” do this /gamerule keepinventory true
For “nomobspawning” do this /gamerule domobspawning false
To create specific areas, there’s a UniverseGuard command that allows you to block specific mobs!
/rg flag mobspawn <name|id> <false|true>


#26
  • As I said when shutting down the server and reopening everything back as originally with the commands “/ gamerule” in my experience this error has occurred in bukkit, spigot, sponge …
    • “/ rg flag mobspawn id> true”: not possible because my server has over several hundred mobs how to block all?

#27

For the keep inventory you can set the drop flag to false in a Region. That will prevent item drops from players even on death (while if you want to block mob drops you have to set the mobdrop flag for that mob).
For the mobspawns, as Anti_Spastici suggest you can set the mobspawn flag to false if you want to block it, but i understand that having a tons of mobs could be a problem, so i’m working on some methods to block mob categories with one command (for example, if you do /rg flag mobspawn allhostile false all hostile mobs will no longer spawn). I hope this won’t take time to develop, so stay tuned for more updates :wink:


#28

Hi! Thanx for the grat work! I have a problem with the mobspawn from /rg help 8 … is it a flag or?


#29

Yes, mobspawn is a flag wich will prevent a specified mob from spawning (can be a vanilla mob or a mod mob).
More details can be found here :slight_smile: https://github.com/JimiIT92/UniverseGuard2/wiki/flags#mob-flags


#30

Thank you so mutch for the fast replay! I just have this problem that when i try to use this flag…see the screenshot:

Can I configure it directly her:

{
  "EXPLOSION": "enderdragon",
  "DAMAGE": true,
  "DESTROY": true
}

],
“MOBS”: [],
“COMMANDS”: []
}

I use FTB Beyond


#31

That’s because the syntax is wrong. You should type /rg flag mobspawn [mob name or mob id] <true | false> Consider that the ability to block all mobs (or mob categories) at once will be added in the next release


#32

Okay so I do /rg edit spawn and then /rg flag mobspawn false

All my other flags works like a charm :smiley:


#33

You have to specify wich mob you want to block the spawning. If you do just mobspawn false it won’t work, you have to do mobspawn [mob id or name] false

(Noticed now that Sponge cut some part of the message)


#34

Okay! yay…But now i have to find alll the bad guys :slight_smile: in spigot it just one command :slight_smile:


#35

I know this is a problem and i’m already working on a way to disable all mobs at once, so stay tuned as next update will have this feature :wink:


#36

Thank you so much for the work you put in to it! It works now the worst of them are not spawning in the spawn thats the importent part :smiley:


#37

“Francesco_Jimi” I would like to ask if you can add a flag that does not allow players to leave the area? It is similar to the “Exit flag” of the “worldguard” which does not allow the player to try to escape.

My RPG server all the maps are made by hand and players are only allowed to work in the allowed area.


#38

I’ll try to add that flag in the next release :wink:


#39

Why exactly did you need to make a sequel? Couldn’t you have just updated your previous project?


#40

hello :slight_smile:

Do you think the Supports for latest versions (built with API7 like 1.12.2) will be here in the next days ?

I hope :stuck_out_tongue:

good job for your plugin !


#41

This is what he said before. Old version has too many errors or something. xD