UniverseGuard - A WorldGuard Solution for Sponge


#226

I’m using UniverseGuard 2.2 with spongeforge 1.12.2-2555-7.0.0-BETA-2797 and It won’t let me have the region selector, in the console the following error is appearing constantly.

[10:53:16] [Server thread/ERROR] [Sponge]: Error occurred while executing command ‘region’ for source EntityPlayerMP[‘Kreezxil’/801, l=‘world’, x=36.35, y=63.88, z=232.00]: org/spongepowered/api/data/meta/ItemEnchantment
java.lang.NoClassDefFoundError: org/spongepowered/api/data/meta/ItemEnchantment
at com.universeguard.utils.InventoryUtils.getSelector(InventoryUtils.java:37) ~[InventoryUtils.class:?]
at com.universeguard.command.RegionExecutor.execute(RegionExecutor.java:35) ~[RegionExecutor.class:?]
at org.spongepowered.api.command.args.ChildCommandElementExecutor.execute(ChildCommandElementExecutor.java:247) ~[ChildCommandElementExecutor.class:1.12.2-2555-7.0.0-BETA-2797]
at org.spongepowered.api.command.spec.CommandSpec.process(CommandSpec.java:383) ~[CommandSpec.class:1.12.2-2555-7.0.0-BETA-2797]
at org.spongepowered.api.command.dispatcher.SimpleDispatcher.process(SimpleDispatcher.java:342) ~[SimpleDispatcher.class:1.12.2-2555-7.0.0-BETA-2797]
at org.spongepowered.common.command.SpongeCommandManager.process(SpongeCommandManager.java:322) [SpongeCommandManager.class:1.12.2-2555-7.0.0-BETA-2797]
at net.minecraft.command.ServerCommandManager.func_71556_a(SourceFile:1083) [dh.class:?]
at net.minecraft.network.NetHandlerPlayServer.func_147361_d(NetHandlerPlayServer.java:958) [pa.class:?]
at net.minecraft.network.NetHandlerPlayServer.func_147354_a(NetHandlerPlayServer.java:937) [pa.class:?]
at net.minecraft.network.play.client.CPacketChatMessage.func_148833_a(SourceFile:37) [la.class:?]
at net.minecraft.network.play.client.CPacketChatMessage.func_148833_a(SourceFile:9) [la.class:?]
at org.spongepowered.common.network.PacketUtil.onProcessPacket(PacketUtil.java:149) [PacketUtil.class:1.12.2-2555-7.0.0-BETA-2797]
at net.minecraft.network.PacketThreadUtil$1.redirect$onProcessPacket$zjp000(SourceFile:539) [hv$1.class:?]
at net.minecraft.network.PacketThreadUtil$1.run(SourceFile:13) [hv$1.class:?]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_151]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_151]
at net.minecraft.util.Util.func_181617_a(SourceFile:46) [h.class:?]
at org.spongepowered.common.SpongeImplHooks.onUtilRunTask(SpongeImplHooks.java:274) [SpongeImplHooks.class:1.12.2-2555-7.0.0-BETA-2797]
at net.minecraft.server.MinecraftServer.redirect$onRun$zif000(MinecraftServer.java:4007) [MinecraftServer.class:?]
at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:721) [MinecraftServer.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:396) [nz.class:?]
at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:666) [MinecraftServer.class:?]
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:524) [MinecraftServer.class:?]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_151]
Caused by: java.lang.ClassNotFoundException: org.spongepowered.api.data.meta.ItemEnchantment
at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191) ~[launchwrapper-1.12.jar:?]
at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_151]
at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_151]
… 24 more
Caused by: java.lang.NullPointerException


#227

Thank you for using my plugin :slight_smile: I know about this issue and the problem is that 1.12.2 uses API7, while the plugin uses API6. An API7 version is in development and will be released shortly after the official release of Sponge API7 (wich will launch at the end of this month), so stay tuned for updates :wink:


#229

How do I disable all mobs spawning within the region? I do not have the time to specify every single mob in the modpack I am running.


#230

Disabling all mobs with one command is a feature that will come in the next release, wich will be today! So stay tuned on the UniverseGuard2 thread to know when it’s released :wink:


#231

is there any API 7 ver for 1.12.2???


#232

he is still working on it


#233

I’m working on it. Unfortunately is not easy as i thought, since some events has been changed significantly, so they have to be rewrite (and this is time-consuming) :confused:


#234

then seek help if you can not do it alone! its a shame that there is no right worldguard alternative for sponge…


#235

Hii, sorry my english, i’m telling german.
I’m have 2 Problems:
Ingame Error-> /rg flag chests true -> Error Subflag. What it’s a Subflag?

Problem Global-Config - Server stay down. I’m edit the global config in the path
~/config/universeguard/globals/world.json
the flag chests to true, but after serverstart stay chests to false and players don’t have access to chests in the world.


#236

This universegurad version is very old, pls use the new one Universe Guard 2: an easy to use world protection plugin

Edit:
If you’re using the new version and still have this problem than is the reason simple, the plugin does now cache all the information, to apply the changes you made manually form the config file do /rg reload


#237

Oh, sorry. I’m use the UniverseGuard2 and now wrote in the right section for the plugin. :slight_smile:


#238

Do you have plans to introduce a greeting and farewell flag like world guard has?


#239

Those flags will be in the next release coming later this week in the new version of the plugin. You can read more about it here :wink:
https://forums.spongepowered.org/t/universe-guard-2-an-easy-to-use-world-protection-plugin/


#240

Thanks for your quick response Jimi, Will the updated version be ForgeSponge 1.10 compatible?


#241

Right now i’m focused on the Api7 version, but i’m porting everything i can back to 1.10 since it’s still used by many :wink: i’ll try to have a universal version but i don’t know if that will be possible since there are a lot of differences between api6 and api7


#242

Hey!
A little question.
I have to leftklick for the first and rightklick for the Second point with the Region-Tool ?

On My Server runs Immersive Craft, so when i rightklick on the ground, i put a stick on it.
Can i switch the Tool ?


#243

It will but i recommend you to update to 1.12.2, since many plugins are dropping support for that version and if i can’t make a version that is compatible with both api 6 and 7 i will drop support for 1.10 too as well


#244

1.12.2 Runs on Server… sorry this forums is new for me, dont know where i have to write :sweat_smile:


#245

Yes, this is correct. Unfortunately you can’t set wich items is the selector right now :confused: You can try to shift-right click, but by the way the point should be selected even if the stick is placed, so you can remove it after it placed it and you should still have the point selected


#246

Tested, but dont work. Game say “You must select two points”.
Dont work with shift rightklick and only rightklick.