VirtualChest - Provide virtual chest GUIs for menus like ChestCommands (SpongeForge/SpongeVanilla 1.10.2, 1.11.2, and 1.12.2)


#41

It broke it the latest versions of sponge. It can't be reproduced in 2259


#42

Oh, no...
This sponge version has inventory fix. I need it.
It turns out that the following versions of a sponge have this fix too, so the plugin will be with a bug further. By the way, now secondary and primary clicks for unknown reason don't work. I will better refuse a plugin in favour of updates of a sponge.


#43

Ok, fixed. @Lefty @SnowBlitzz @tridaak @LC_Games
Try the latest version (v0.3.1) now.



The reason is that Sponge has inconsistent implementation of higher versions.
A slot has a parent. In the older version of sponge, inventories are grouped and the parent of the slot is only the red rectangle as shown below:

while the parent of the slot is the whole inventory in the higher version. That causes the inconsistency.

#44

Thanks for fix :slight_smile: Will test it out later.


#45

Yes thank you :slight_smile:


#46

Good day ZZZZ
i seem to have a issue when i am using your plugin people are able to put items into the GUI itself and then when they click it they lose there items.


#47

@xskymaster, You must install latest version of VC and Sponge.


#48

I've been able to replicate this issue with latest SpongeForge and VC.


#50

I tried the latest version of Forge(2281) and SpongeForge(5.2.0-BETA-2292), while I didn't reproduce the bug successfully. Could you give me some more information about the versions of your server?


#51

Can we use this plugin as a sort of global market type plugin or is this different


#52

To reproduce the bug, make sure you have empty slots in the virtual chest. Then put an item in the empty slot. Gonna update my sponge version and test it out again to see if the problem's still there, if so, Ill send a list of all the plugins I have


#53

http://imgur.com/a/LdciA Order is backwards, don't have screen capture software to make a clip.

├── Nucleus-0.28.1-1.10.2-S5.1-plugin.jar
├── PixelExtras-1.10.2-2.2.5-universal.jar
├── Pixelmon-1.10.2-5.0.3-universal.jar
├── PixelmonEconomyBridge-1.10.2-1.3.0.jar
├── spongeforge-1.10.2-2281-5.2.0-BETA-2300.jar
├── TabManager-1.0.4.jar
├── TrainerCommands-1.10.2-2.1.5-universal.jar
├── VirtualChest-0.3.2.jar
└── worldedit-forge-mc1.10.2-6.1.4-dist.jar

These are all the mods I have, using latest version of VC, Forge, and SF.


#54

Well, I reproduce the bug successfully, and that's my fault.
Please try v0.3.3 now.


#55

Tried it, it works perfectly. Thank you :slight_smile:


#56

You will add function of economy?


#57

Thank you moderators for Posting more on www.mcbbs.net in China. I happen to be from China, and it's a lot easier to visit Chinese websites


#58

Boy am I glad that this exists. While I don't intend to depend on this, it's definitely a great resource in helping me understand how to work with custom inventories in sponge. You get a thumbs up from me!


#59

Sometimes when I go back and forth with menus the GUI will just disappear.

For example I have an icon in gui1 that has primary and secondary action vc open gui2 and an icon in gui2 that has primary and secondary action vc open gui1

When I click on them back and forth sometimes the GUI will just disappear. The speed of pressing them does not matter.


#60

%player_name% don't work. It do command with this tag.
[20:41:50] [Server thread/INFO] [nucleus]: Server ran the command: /world teleport DIM-1 %player_name%
that I have:
PrimaryAction = "console: world teleport DIM-1 %player_name%"
SecondaryAction = "console: world teleport DIM-1 %player_name%"


#61

Make sure that you have installed the PlaceholderAPI plugin and enabled it in the virtualchest.conf:

virtualchest {
    placeholders {
        # If set to true, the plugin will use the PlaceholderAPI instead of the placeholders provided by the plugin itself.
        use-placeholderapi=true
    }
}