VoxelSniper - Long Range Terrain Editing [v8.0.0] [1.8.9 // 1.10.2]


#42

Does this release include smooth brush and overlay/underlay brush ?

Edit : yup it does, fantastic ! I really like the possibilities offered by your plugin :smiley:


#43

awesome! how to choose a brush?


#44

Scrolling five posts up, there's this:

Also, docs:


#45

Does this new update include the stencil list?


#46

Stencil selection doesn't seem to want to work. When selecting a cuboid I click and it tries to set both points with the first click. I tried to mess with it for quite a bit to try to nurse to it get the selection of the blocks I wanted but to no avail.


#47

Hello.
I installed the version spongevanilla-1.10.2-5.1.0-BETA-366 of sponge. I put the plugins of 1.10.2 in the mods folder but when i run the server, nothing happeneds. The plugin won't load


#48

Please share the latest server.log file with us (eg. via pastebin). If VoxelSniper failed to start, there should be an error in there somewhere.


#49

I read it and it says 1 plugin is found and i guess is VoxelSniper-8.0.0-SNAPSHOT.jar but when i run the server still /b and /v (and the entire plugin) won't load


#50

Your problem is obvious, even if the log file is truncated.
You have VoxelSniper-8.0.0-SNAPSHOT-javadoc.jar, alongside the expected mod file you have installed the VoxelSniper javadocs and sources. Re-download VoxelSniper , but this time get the VoxelSniper-8.2.0-SNAPSHOT.jar file (and get rid of any others). That should fix your issues ...


#51

Still Not Fixed


#52

I'm confused here. Last time you had spongevanilla-1.10.2-5.1.0-BETA-366.jar. That looks like the startup from vanilla minecraft to me. Just check you have it installed and launching correctly: https://docs.spongepowered.org/master/en/server/getting-started/implementations/spongevanilla.html


#53

I re download the server, now i'll see


#54

Perfect now as i open the server it close.


#55

There appears to be multiple attempts to launch a server on that log.

[14:57:52] [Server thread/WARN]: **** FAILED TO BIND TO PORT!
[14:57:52] [Server thread/WARN]: The exception was: java.net.BindException: Address already in use: bind
[14:57:52] [Server thread/WARN]: Perhaps a server is already running on that port?

Somehow it has several server instances running, or trying to. You might need to kill all java processes and start again. Make sure it's only launching the one server ...

POST EDIT: this build is the most recent one for API 5.1.0: http://ci.voxelmodpack.com/view/VoxelSniper/job/VoxelSniper/442/


#56

Well i understand that too but there is no java process open. NOW i'll try to restart pc


#57

Well i restart my pc and now server works but it looks like it became a vanilla server (my log http://pastebin.com/gKHqKUSj) but when i click spongevanilla-1.10.2-5.1.0-BETA-366.jar and i click my server it start to crash as before. http://prntscr.com/dogp0h


#58

Please, >> READ THE DOCS <<. They're there to help, and save us repeating stuff like this to everyone.
On the page I linked above, it says very clearly:

Warning
Don’t double-click the .jar file!

Create a script to launch it, as it recommends in the SpongeDocs.


#60

I recently installed the latest build (446) but when i do /b over d# the gunpowder will not add layers instead it will do the same job of arrow, any help?


#61

The ScraM team has done some work on the erode brush with lift mode. It still doesn't work deep underwater, but in shallow water and open air it seems much closer to the old VoxelSniper behavior.

The diff file is here: http://scram.frequal.com/scram/VoxelSniperErodeBrush.diff

-ScraM Team

ScraM: Make your own mods, stories, and minigames


#62

Hi, I have some problems with /b over brush
Everyone says that when you use this with gunpowder it supposed to create a new layer of blocks, however, for me it works similar to the arrow (replacing blocks)
Does anyone know how to make gunpowder work like I want to?