"A fatal error has ocorred, this connection is terminated" Sponge + Dalek Mod


#1

Hello guys, guess what? Big problem here :confused:

I’m trying to run a server with my friends with the latest dalek mod and some plugins on sponge, everything is working fine, i’m mean, no bugs, no errors… Except, when you try to set a destination in the TARDIS… The mod works creating about 3 or 4 worlds that you can travel to using a interface, but everytime you choose a world and click in “Save” you are disconnect and get this message: “A fatal error has ocorred, this connection is terminated.” I searched everything looking for a fix, I saw something about “netty leak” but i don’t know what that means, neither how to fix it

I’m running Sponge 1.12.2-2611-7.1.0-BETA-2983

Here is what shows me in the prompt

If anyone can help i would be very greatful! :smiley:


#2

What plugins are you running?


#3

I’m using just the sponge and the dalek mod, but i found a way to make it work. For some reason when i use the Sponge 1.12.2-2611-7.1.0-BETA-2929, the fatal error doens’t happens anymore, forward versions cause that conflict. I’m using this version for now, but i really want to keep my server updated, so i’m waiting for others solutions


#4

@EM_BLOCOS can you please post the mods (and their versions you are using), the versions of Sponge, and the entire log file anyways?

It is always good to post details, even if it just seems to be a weird version quirk, because it might be caused by something that the Sponge team should be aware of.


#5

Well, I don’t know how can I get the full log, but here’s everything that I was using:

SpongeForge version: Sponge 1.12.2-2611-7.1.0-BETA-2983
Forge version: Forge 1.12.2 - 14.23.2.2635
Java version: Java 8u161
Operating System: Windows Server 2012
Mods: Dalek Mod update 47 (https://swdteam.com/p/dalek-mod)


#6

The full log is in logs/latest.log.


#7

Sorry about the delay, here it is


#8

What about fml-server-latest.log?


#9

Alright, here!