Latch - A locking plugin to protect your containers


#21

Hi. I have a few suggestions:

It would be nice if you could make something similar to this: http://nucleuspowered.org/docs/modules/home.html#limiting-the-number-of-homes. So setting the limits over permissions.
Also if protecting a chest/block could cost money, that would be awesome too!
Additionally MySQL support would be awesome!


#22

Hey @BrainStone thanks for all of the suggestions. These are definitely on our list, but we unfortunately do not have too much time to work on them at the moment. Soon we will be back on top of it, getting these features and even more completed. The lock limits as options is already a work in progress actually, I hope to get back to it soon :slight_smile:

Sorry about the wait!


#23

I might actually be able to help out with coding. Especially the database stuff.


#24

Well I'd be delighted to work with you to get a pull request in :smiley:

The whole design of Latch could use some work but it should be fairly intuitive, and if you need some help I'm often on IRC and Discord with the same name as here.

Here is the Github: https://github.com/IchorPowered/Latch


#25

:lock: Latch v0.4.3

As always I recommend you use the latest build of Sponge matching your version and you keep backups of your lock database!

This release is a relatively small one, with a few improvements and bug fixes. Most notably we have added support for Sponge’s reload command(/sponge plugins reload) and fixed an issue which made it so both parts of a chest wouldn’t be locked. There may be some very small performance increases in some areas as well. The rest of the changes were just small code style changes, which should not affect the plugin. I hope you enjoy this release and as always if you have issues or suggestions please report them on our Github.

You can find this release on our Ore.

Features

  • Support for Sponge’s plugin reload command and event.

Bugfixes

  • Fixes issue where the other part of a double chest would not lock automatically or when a single chest was expanded.
  • Other general fixes :>

Code/project changes

  • Added @connorhartley as one of the developers
  • Updated the Gradle wrapper.
  • Continued general code and style cleanup throughout the whole plugin.
  • Made more variables final where appropriate
  • Create the info message statically so it does not have to be done every time someone runs the command.
  • Updated to bstats-sponge-lite 1.2 from 1.1
  • Updated the shadow plugin from 1.2.4 to 2.0.1 to fix some issues and to keep up to date
  • General miscellaneous changes.

#26

Hey,

In the v0.4.3 bugfixes it says you fixed the issues with double chests but I’m still unable to lock them on this version (I can lock the single chest when placing but when expanding it it can be opened from the side it was expanded on and I can’t /latch private the second side and attempting to /latch private an already placed chest doesn’t do anything).

Could I be doing something wrong or is there still an issue?


#27

I thought I fixed the issue, but I may have missed something or there could be a problem with the version of Sponge you are using. Mind providing me with that?


#28

I’m using 5.2.0-SNAPSHOT-c675e80


#30

A new version has been released for Latch, it is available for download here.


:lock: Latch v0.4.6 for Sponge API 5.2.0

As always I recommend you use the latest build of Sponge matching your version and you keep backups of your lock database!

This release is very minor, fixing a slight issue with double chests.

If you are running an API 7 build which I highly recommend, use that build of Latch instead. This will most likely not work.

Bugfixes

  • Fixed issue with double chests sometimes not locking properly

Code/project changes

  • Built with latest 5.2.0-SNAPSHOT build
  • Update license to 2018
  • Remove bStats as I don’t look at it anyways

#31

A new version has been released for Latch, it is available for download here.


:lock: Latch v0.4.7 for Sponge API 7.0.0

As always I recommend you use the latest build of Sponge matching your version and you keep backups of your lock database!

This release is very minor, fixing a slight issue with double chests and updating dependencies to stable API 7.0.0.

If you are running a release before API 7 or one of the earliest API 7 releases, please use Latch v0.4.3 for now. I highly recommend you move to stable builds of API 7 or 7.1 as soon as possible though!

Bugfixes

  • Fixed issue with double chests sometimes not locking properly

Code/project changes

  • Update to API 7.0.0 stable
  • Update license to 2018
  • Remove bStats as I don’t look at it anyways

#32

Thanks a lot for this plugin <3 !!


#33

Hey ! I use the latest version on sponge api 7 SpongeForge 1.12.2 and the file latch.conf isnt created, have you any idea ?
This my log : https://gist.github.com/Flashback083/31f88ab580192e7902f7efe9ed7572c1
Thanks !


#34

Sorry about the late response, is this still happening? The issue is not something Vectrix and I have been able to reproduce, and it’s not really an issue that should be happening. Could you make sure you’re using the latest 7.1 build of SpongeForge and compatible Forge and test again, then if it occurs again can you send me your exact versions and your mod list?

I hope we can get it to work!


#35

Thanks for your kind words tryolivier, I’m glad we’re able to make a plugin you enjoy. We don’t have much time to work on new features right now, but is there anything you’d like to see in the plugin?


#36

Yes i think the sames commande like lwc

like cprivate or cmodify @pseudo1 @pseudo2

And maybe not only chest door . …

But too other mods bloc like computer
Or drawer

Thanks


#37


this is my log error, im running latest recommended sponge version / forge (1.12.2 / api 7)
Thanks :confused:


#38

Can I see a list of your mods?


#39

Of course !
AutoRegLib-1.3-15.jar
cfm-4.1.5-mc1.12.jar
Chameleon-1.12-4.1.3.jar
CustomNPCs_1.12.206feb182.jar
ironchest-1.12.2-7.0.34.820.jar
malisiscore-1.12.2-6.3.2.jar
malisisdoors-1.12.2-7.2.4.jar
MorePlayerModels_1.12.2(18jan18).jar
Pixelmon-1.12.2-6.2.1-server-patched2.jar
Quark-r1.4-121.jar
Shulker-4.0.jar
VariedCommodities_1.12.2(06nov17).jar
Do you need my sponge plugin ?


#40

May I introduce this plugin to Chinese players?


#41

hello @Meronat have you tryed to do that ??

thanks :wink: