Minecraft Server - SpongeForge - Raspberry pi 3b+ - Raspbian


#1

Hi gents,

I am currently running a spigot server on my RPi. I must say it works pretty well. But then, I discovered some very intersting mods (Biome O Plenty, MO Creatures, etc.) and unfortunately, this is not compatible with spigot.

So I need to run a Forge server (I am quite confuse with SpongeForge name).

Do you know if it can work ?
Do you have some tuto to do that because I am having some troubles to install forge ? (scala library thing …).

Thank you in advance,

I am looking forward your answer so I can have fun with my family :slight_smile:

Have a good day,

Raspomain


#2

The docs are a pretty good place to start reading: https://docs.spongepowered.org/stable/en/server/getting-started/implementations/spongeforge.html

There’s also translations available if English is not your native language.

If you have additional questions, feel free to respond here and someone from the community will respond within the day or so.


#3

Well of course I tried to follow the doc first.
But I have an error

Error

These libraries failed to download, try again.
com.typesafe.akka:akka-actor_2.11:2.3.3
com.typesafe:config:1.2.1
org.scala-lang:scala-actors-migration_2.11:1.1.0
org.scala-lang:scala-compiler:2.11.1
org.scala-lang.plugins:scala-continuations-library_2.11:1.0.2
org.scala-lang.plugins:scala-continuations-plugin_2.11.1:1.0.2
org.scala-lang:scala-library:2.11.1
org.scala-lang:scala-parser-combinators_2.11:1.0.1
org.scala-lang:scala-reflect:2.11.1
org.scala-lang:scala-swing_2.11:1.0.1
org.scala-lang:scala-xml_2.11:1.0.2
There was an error during server installation

I tried to DL manually the scala library and I followed the instructions but there is still these errors …

Someone has an idea ?

Thank you,

RM


#4

Do those issues arise when installing forge, starting the server, or installing sponge?

If it’s installing forge:

  1. this is probably a better thing to ask in the Forge Forums or Discord.
  2. it sounds to me that for some reason, the repo that those files are downloaded from is unreachable. I vaguely remember having this issue before, and I think my solution at the time was to just try again.

If it’s either of the other two then I have no idea.


#5

It’s during the installation of Forge.
Actually, I checked and folders are created. And I can find some files inside each folders but for example their names are like :scala-compiler-2.11.1.jar.pack.xz
It seems the DL of these files connot be achieved, right ?

What confuses me is I DL the scala-library (right version) and put it in the righ place. But still, the Forge installer prefer to DL files instead of using the scala-library.jar directly…


#6

If you manually download all the files and place them in their folders it will work, however the better way would be to run the installer using -Djava.net.preferIPv4Stack=true when running the installer after deleting the broken pack files


#7

Where can I find all these files ?
I found some in Marven Repository but not everything … As it is forge for the last version of SpongeForge, can someone give me all the files ? It would be very nice :slight_smile:


#8

Alright, I downloaded all the files. I checked : it is the proper name, and I replaced all broken files.
Still I have this error :
These libraries failed to download, try again
org.scala-lang.plugins:scala-continuations-library_2.11:1.0.2
org.scala-lang.plugins:scala-continuations-plugin_2.11.1:1.0.2
org.scala-lang:scala-xml_2.11:1.0.2
There was an error during server installation

Problem is, I double checked and I replaced one more time broken files : the good files .jar are systematically destroyed and replaced by partial ones …
This is very strange because I DL exactly the name of the broken parts created by the installer (except it is .jar instead of .jar.pack.xz of course)

Any idea ? :frowning:


#9

Have you tried running it on a different computer? If it works just copy the files between. If not, I’ll do some research later. You would probably have better luck finding Forge related help on the Forge forums.


#10

Well I think I will try this …
I posted on Forge forum but no response … I just saw a guy has got the same problem than me ! Exactly the same ! I gave him the solution I tried, We will se if he got the same remaining broken files.


#11

Assuming that you’re running this via a command line you should be adding the suggested to the end of the command and it should download correctly


#12

I am already using this mod in my command line