Minecraft Sponge Plugin-update from 1.8 to 1.9.4


#1

Hey there! :smile:
Before i start i just want to say that im completely new to the sponge api and coding.
I just want to know how to update a plugin xD


#2

Lovely and blunt…

The 1.8 and 1.9 apis are both out of date and very few will help you. What’s problems does your ide give you?


#3

Well, you re-import the Sponge-API’s jar of 1.9.4 instead of 1.8 and fix up the errors


#4

@JustinusIuvenis Which plugin?


#5

Its a small plugin which is used for some pvp projects
its hard to explain xD


#6

maybe give us the code and we could tell you how to update it from there


#7

The problem is that the plugin was not made by me.


#8
  1. What’s the license on the plugin?

  2. We don’t need the whole plugin, just the bits you can’t port yourself.

  3. If this is a question of “how do I program, I’ve never done it before” then the answer is you are not going to be able to do this without learning to program / make sponge plugins in the first place first.