Play random sound file as user joins server


#1

I’ve been trying to find a way to play a sound when a player joins the server. And if possible, a random sound file from pool.

Is there any current plugins that will allow me to do this?

Thanks in advance :slight_smile:


#2

Are you looking to play custom sounds or sounds built into minecraft?


#3

Custom sounds yeah


#4

Sound effects that broadcast it to all players or just a clientside join in sound effect only to that player?


#5

Custom sounds will require a resource pack on each client.
I don’t know of any plugins that can do this, yet.


#6

you need to be more specific on what you want and explain more
cause if you just want a minecraft sound effect for every player that join the server this is possible


#7

A resource pack would not be a problem as it’s a small closed server. If I had the sounds installed on all clients would there be a simpler way to play the sounds on join?

I’d like to play for everyone server wide. If not then only to the player joining would be fine.


#8

so it’s a custom sound effect not minecraft sound types?


#9

Yes, Custom Sounds.


#10

Then this is not possible with Sponge. It’s only possible with Forge Api


#11

I have All the Mods 3 which has Forge included. How would I go about it?


#12

You would have to create a basic Forge mod. Need basic java knowledge or find a nice force mod that public out there.


#13

There’s support for custom sounds on the SpongeAPI, he just needs the resourcepack with the sound file and a plugin for the server side.


#14

Yeap your right i was just speaking out without resourcepack it’s not possible


#15

I have an idea of how to make it work using Nucleus however I cannot find a Permissions system that works with the latest SponeForge. Which do you guys use?


#16

Permission plugin? it’s recommended to use LuckPerms plugin


#17

Thanks, I tried it but it doesn’t seem to be loading with the server start. I guess it’s not working with API 7 yet?


#18

It Does work with API 7


#19

What could I have done wrong then? I’ve installed SpongeForge okay. Nucleus okay. Both by dropping the .jar into the mods folder.

When I do the same as instructed on the LuckyPerms docs nothing happens on server boot. No config files created etc.


#20

Thanks, btw. for all the help you have given.