PSA: Dropping 1.9.4 support


So, it has come to the time where the Sponge Team has elected to drop 1.9.4 support entirely. The reasons for this are purely from a moving forward standpoint. While 1.9.4 was our first version update to the Sponge ecosystem, we've learned a lot with the update process, and we've found how difficult is it to keep three versioned branches sitting around in active development. In the long run, the modding community has already started jumping ship to 1.10.2, and the vanilla community is not going to stick around for 1.9.4 as long as 1.10.2 is available.

That being said, Sponge API 5 will be targeting 1.10.2 as well, since no API release has been made for the 1.9 development cycle, we aim to have API 5.0.0 released very soon.

It is worth noting that Sponge API 4.x is still in LTS and SpongeForge for 1.8.9 is LTS, so any fixes and bug reports will be taken care of.



Will you drop 1.10 support or support both 1.10 and 1.10.2 since there is no major difference ?


By 1.10, we mean 1.10.2 :wink:


Good news! Thanks for this update.


@turtledude01 something for ya