Server has lowping when using Forge 1.12 with Sponge 1.12


Hi guys!

I have a odd issue with FTB Revelation (Minecraft 1.12) and we tried serveral of versions of Forge ans Sponge (to match their version numbers) but after it starts the TPS drops to a unplayable 4.0.

When I remove Sponge from the Forge-mod directory the TPS goes back to 20.00 but I have no clue what this it.

I have no Sponge plugins installed so its only the FTB Revelation (1.6.0) pack with the matching Sponge version.

Is this a known issue in MC1.12? We are now running without Sponge but I really would like to use the Sponge plugins since we use them in our other server aswell.



Can you please:
-post things like logs (using a service like gist).
-give your server details (RAM, CPU, disk, OS, etc.)
-if you use a hosting company, what company.
-have you installed any extra mods to the modpack? I ran it more or less fine as a test…



I dont have any logs anymore but can try to get some.

Server details:

  • 8GB DDR3 RAM for the Java service
  • CPU: Intel Xeon E3-1225 V2 @ 3.2 GHz
  • CentOS Linux 7.4
  • Oracle Java 8u161

Dedicated hosting at OVH

Installed no additional mods (besides Sponge) to the modpack, stock Rev 1.6.0. Also none Sponge plugins installed