VoxelSniper - Long Range Terrain Editing [v8.0.0] [1.8.9 // 1.10.2]


#63

I'll get to some of these errors soon once my current project has shipped, just so it doesn't feel too abandoned in here.


#64

I'm having the same error. Please fix it! :heart:


#65

I've just released version 8.3.0 since there have been make improvements and fixes since the last release (I also just fixed that overlay bug)

The full changes since the last release are:
- fix behaviour of erode brushes on ties to match older behaviour
- fix selecting large trees with the tree brush
- update jockey brush for latest spongeapi changes
- add configuration for expiring player data after a period of time
- actually load configuration, a new configuration file will be created on first load
- reload configuration when /sponge reload is called
- add ChangeBrushSizeEvent
- fix error with splatter brushes
- add --legacy flag to stencil brush to specify loading/saving the stencil with the mcedit schematic format
- disable three-point circle brush
- fix large trees not displaying properly in the info message
- fix splatter brush parameters not being able to be set properly
- fix overlay brush with gunpowder not adding a new layer of blocks

Download: https://ore.spongepowered.org/VoxelBox/VoxelSniper/versions/8.3.0


#66

I dont know, maybe i do somethink wrong but i cant add new block from dunpowder (RMB click). It’s strange… on bukkit version all works… Anyone will help me?
Even it’s doesn’t work after changing version!


#67

Hi, ive just moved from spigot 1.7.10 to sponge 1.10.2 and ive yet to get accustom to the new material names over the more convenient block ids. its a lot of time wasting having to type the name of the material every time i want to change the block when i could just type the id and its variant with vi as i have always used to.
for example:
this
/v minecraft:stone[variant=diorite]
is far too much to type compared to this
/v 1 /vi 3

yes, you could argue that you can just point at a block and type /v but that only works for blocks already placed and i often use it to retrieve and replace blocks on the fly or checking a block id quickly.

could we please have the option to use block ids on top of the new way of having to type out material names? worldedit already allows both methods to be used and im not seeing the logic behind straying away from it.


#68

Block and item integer ids are a deprecated concept that are not directly accessible through the SpongeAPI, and that is for the reason of no implementation being guaranteed to use them or have them match. Minecraft itself has them deprecated and plans to move completely away from them in the upcoming 1.13 update.

For the longevity and compatibility of this plugin, it’s not really a great idea to add this functionality when it will break very shortly anyway. The new system is something you should continue to get used to because it is what will be used everywhere soon enough and already is in most other places in the Sponge plugin ecosystem. It also provides other useful functionality such as not requiring users to know completely random integer ids as well allowing for decent tab completion(which I don’t know if VS supports or not, but it could).


#69

i understand that what youre saying. let me explain my dilemma:
my small server holding about 6-8 active users is exclusively a creative server. we have been stuck on 1.7.10 due to our dependancy on unused metadata to add more textures for use in building.
recently(ish), we have stumbled across a mod for 1.10.2 called conquest reforged which adds 1000s of blocks to to the game in the hopes to restore the massive creative diversity that was removed in 1.8+
the reason for the desperate escape from 1.7.10 is the ability to create custom block models allowing a huge boost in what we can create!
it is a feasable solution, i have begun the conversion of all the textures in our resource pack to work with the mod.
except we have stumbled upon some rather annoying issues thats making me reconsider the decision.
the main issue is that we will have to use sponge as its the only server mod that supports forge integration which we need for conquest reforged. i would love to continue using spigot but unfortunately, currently it isnt possible.
the second issue is the lack of plugins for sponge and ones we frequently used that im struggling to find replacements for (toolbelt for example)
and of course the final issue is the lack of block id integration in this version of voxelsniper. when i was using it on a 1.9 server spigot last year, it worked flawlessly with block id support. but sadly the sponge version has dropped it :frowning:

at this point, due to the amount of issues i seem to run into. we may as well stay stuck on 1.7.10 until mojang adds some kind of method similer to how metadata worked (which probably wont ever happen).


#70

It seems to me, most of these could be accomplished by a proposed feature that VoxelSniper could save your players modes / states on a specific item stack. You could then have these items in a kit to give out to people.

ToolBelt Features:

Block Duplicator (defaults to Stone Axe) Right click with this tool in your hand to get a stack of 64 of the selected block.

Middle Click?

Data Scrolling (defaults to Bone) Right or Left click with this tool to change the data value for the selected block. This lets you change a half-step from wood to stone to brick and so on.

World Edit has a cycle tool that might help, but I agree , this would be pretty cool.

Paint Brush (defaults to Slime Ball) Left click to load a block type and data into the paintbrush, and Right click to paint the loaded data onto the selected block

I thought voxelsniper had similar functionality already.

Leap (defaults to Feather) Right click to make large leaps through the air. This is similar to VoxelAir, only instead of hovering, left click can enter creative mode flight.

Do you use this much?

Pickhax (defaults to Diamond Pickaxe) Left click to insta-delete a block. Right click to insta-delete without applying minecraft physics. Crouch to remove blocks at range (if have phax.range)

Not sure of a direct replacement.

Ruler (defaults to Paper) Left click in one spot, Right click in another, and get the width in x,y,z, total distance between points, and the enclosed volume.

I see this being useful, but if you are forge modding, there are mods that add this much better.

Watch (defaults to Watch) Left click to set personal time to day, right click for night. Crouch and click to re-sync with server time. If synced with server and have watch.server permission, left/right crouch click to set server time to day/night.

This could also be cool.

Sledge (defaults to Gold Pickaxe) Left click to push a block forward into air, right click to pull it towards you. Crouch to push/pull into non-air blocks.

Is this available in VoxelSniper already?

Pliers (defaults to Glowstone Dust) Same as Sledge, except you copy the block instead of move it.

Is similar stuff available in voxel sniper already?

Shovel (defaults to Gold Spade) Left click to remove (by default) a 3x3x3 cube of earth. Right click to remove a disk (by default) of radius 2.5, and crouch right click to remove a sphere (by default) of radius 2.5. By default, the shovel removes stone, dirt, grass, sand and gravel.

Is similar stuff available in voxel sniper already?

Chainsaw (defaults to Gold Axe) Left click to remove (by default) a 3x3x3 cube of trees. Right click to remove a sphere (by default) of radius 2.5. By default, the chainsaw removes logs, leaves and vines.

Is similar stuff available in voxel sniper already?

Tree (defaults to Gold Hoe) Right click to place a full tree where you click, Left click to change the type of tree to place. This uses the built-in tree generation code, and so will only place in locations where there is room for the full tree, and the appropriate ground below. The tool is disabled by default in config.yml .

Is similar stuff available in voxel sniper already?


#71

to be honest, the paintbrush was our primary tool. sniper doesnt work the same way as the praintbrush does, we relied on it being bound to an item set by a config. there was no need to type any commands, it just worked with the bound item at all times.
unlike sniper, the paintbrush is limited range to regular reach, for us to do that with sniper, you have to type multiple commands, in fact you have to type commands to change the block as well which is so much more inconvenient over toolbelts brush tool.
voxel sniper doesnt support legacy numerical ids, this is important for us as we rely on them and will do all the way up to their removal.

in short, the paintbrush in toolbelt has been the simplest and yet the most practical and convenient tool we have used and i wont be using anything else that doesnt work the same way.
voxel sniper has always been for us, a tool for terraforming. its just not practical enough to quickly replace single blocks on the fly.


#72

Hello, excuse me for disturbing you I downloaded the latest version of voxelsniper (VoxelSniper 8.5.0) on my server with Sponge (spongeforge-1.12.2-2555-7.1.0-BETA-2837.jar) and when I type a command on my server I get the following error:
[Server thread / ERROR] [Sponge]: Could not pass InteractItemEvent$Secondary$MainHand$Impl

Thanx you.


#73

cant undo tree brush and cant set tree type for the brush…


#74

I actually have the exact same issue :confused:


#75

OK Project dead…


#76

Hi there, did someone take the maintenance for 1.12.2 ?

Regards.


#77

The latest version from Jenkins (build #478) still works for current Sponge API 7 releases. It was working on the Sponge Community Server last time I checked. Are you having issues with it?